Mycloud viewing problem

#1

I have a strange problem. I had to format and reload all software in my computer. I have 3 Myclouds, 3,4 and 8TB units. Before in file explorer I could see all three under network. Now I can see none(only the computer numbers) Had this problem before and a reboot solved it… If I go to the access icon, I can open one at a time and work with it. If I open a second Mycloud, it replaces the one that was open. I followed all the instructions from support on how to fix the problem to no avail. Running win 10, 64 bit , 16 gig RAM.

#2

Can you reset your router, log into the router, and verify that all 3 my cloud devices have unique IPs?

#3

I had so much trouble getting the router to work and am afraid to do a reset. All the myclouds have unique IP’s and the router is working the same if not a bit faster download speeds. The change was a newer computer (HP) (messed up computer also HP) with a total factory reset with recovery disks.and the problem was there before I reloaded additional software. Thanks for the fast response.

#4

What type of router do you have? A reboot of the router should help by recognizing everything on your network and having it show up on your computers under Network.

On your new computer have you turned on Network Discovery?

#5

I could turn off the router for 1 minute and back on to see what happens. If it does not come up then I am facing 4 to 5 hours of listening to the providers music while I am on hold and there is a language problem. I am American and they speak German. I would have to get my ex in to translate. UGH.

#6

A reboot of the router should not change any router settings that matter; if it does, get a better router…

Since it sounds like you have essentially done a clean install of Windows, I’d check the networking settings very carefully.

I’d have a read of this thread, too:

1 Like
#7

OK, here is what I have done. Rebooted all three Myclouds, reset the router. No help. Got a headache reading the suggestions. Wanted to down load KB 3140743 that was supposed to be a fix, could not find in Microsoft.com any way to do that. Their update catalog could not even find it. I will live with dealing with only one Mycloud at a time and it is good that I transferred files from the three TB to the * TB before this problem came up. Thanks for all the advice.

#8

Make sure each Cloud device has a different name. Also make sure that they are all on the same workgroup.

1 Like
#9

That’s a good point, but I assumed that if the OP was able to see all three devices before, they must have different names. But if they have been reset…

#10

The problem is now solved. Updated all drivers and I can now see all network drives under network in file explorer. Thank everyone for taking the time to help me.

#11

Which drivers did you update? The network drivers on your PC nic? Or are there drivers to the MyCloud local device that I am missing somehow?

#12

I have Driver Max software and I had it update 15 drivers. As I had done a complete reinstall of all software, all drivers were out of date. After the update and a reboot of the computer the problem was gone. I now see all three of my Myclouds in file explorer and can work with them.