New issues with browsing to my MyCloud


#1

Past couple of weeks I’ve had this issue - I can no longer \ browse to my MyCloud shares.

My primary router is a DHCP server for my home network, and is hard-wired to a 2nd old router that’s running dd-wrt as a “client bridge.” My MyCloud drive has a fixed IP address, and I can log into it via the interface thru my web browser. My firmware is up-to-date.

At first, I thought that my laptop was connecting to router 1 but the MyCloud to router 2, and that was the problem. I don’t think that’s the problem.

My laptop is in a workgroup called WORKGROUP. The other day, my MyCloud was also in that same workgroup. Today, it is not (though it is set up to be, in the UI - I use Advanced IP Scanner to see the workgroup).

I can ping the IP address of the MyCloud. I cannot ping it by name. I have flushed and re-registered DNS on my laptop.

I stumbled on info that says Windows 10’s lovely automatic updates may have disable something that I need to browse to my MyCloud: SMBv1. I have no idea what this is – but I followed WD’s instructions for reenabling it, rebooted, and my device shows up under Storage and Media Devices now, in the Network Explorer – but the storage icon disappears and reappears. I can’t really do anything with it.

WD - tell me what I’m doing wrong! I need to get to my files, and back up my laptop!


#2

UPDATE: Found this @ https://social.technet.microsoft.com/Forums/en-US/e43bdd35-6dc6-4182-b7a4-1b77cb7fc16a/following-upgrade-to-windows-10-nas-unit-does-not-show-under-quotnetworkquot?prof=required and I think I can do what I need to, again (after doing various things with SMB et al):

Check the following registry key - \HKEY)CURRENT_USER\Software\Microsoft\windows\CurrentVersion\Explorer\MountPoints2
Delete anything with ## in front of it. Then restart the computer
If I ever have an issue with disconnected drives or drives with red X’s against them showing up. Deleting these keys usually resolves it.


#3

I am still having these issues. Can anyone advise? I cannot even connect to my MyCloud using its IP address in the browser address bar, anymore. “This site can’t be reached.”


#4

Check your router’s DHCP section to see what IP address the router is handing out to the My Cloud. Generally it is recommended to reserve an IP address for the My Cloud within the router’s DHCP section. That way the My Cloud will use the same IP address every time when it is booted/started up or rebooted/restarted.


#5

Thanks. I am reserving, via the MyCloud’s MAC address, an ip address for it. Part of the problem may be (forgive any incorrect terminology, here) that I have 2 routers using the same SSID in an attempt to “extend” my wifi through my long ranch house. I have a main router in the center of the house that acts as DHCP, and I have an older linksys running dd-wrt that is immediately adjacent to the MyCloud. It’s that secondary router that’s reserving the IP address for the MyCloud. I rebooted both that router and the Mycloud, and the problem disappeared – for now.


#6

Generally you will have issues if you are attempting to run two DHCP servers both trying to hand out the same subnet IP address range to network clients. Normally when using two routers one would disable DHCP on the secondary router to prevent issues. This assumes you are not creating different IP subnets (ex. 192.168.0.x and 192.168.1.x). If you have created two different IP subnets then you may need to configure the router(s) to pass traffic between those subnets.

Also when using two routers one would typically disable the firewall on the second (down stream) router. Some routers will have a preconfigured setting for WiFi extender mode or AP mode where the firewall and DHCP server are disabled automatically.