MyCloud out of space, cannot access files anymore


I have a MyCloud v04.05.00-315 where I run out of space (0 KB left). Now, I cannot access the files on MyCloud anymore. I am able to list some folders and their content (sometimes a timeout will occur), but I cannot do any file operations, especially not delete files. I still have access to the dashboard, though.

I restarted MyCloud, tried Win10 and Ubuntu to access the files, and tried FTP and HTTP. I do not use SafePoints.

I am happy for any suggestions on how to solve this problem.

There seems to be a flaw in the MyCloud firmware design that allows it to run out of disk space, which renders the operating system unusable. It’s possible that a 4-second reset will clear enough temporary swap space to allow you to regain access. I thought I’d seen previous reports of this problem, but I can’t find any with the obvious search strings…

If not, then you may have to resort to removing the disk from the enclosure, and recover the data, or make some space.

If you can access the My Cloud using SSH you can get in at the root level and delete your folders/files to free up space.

Hi, it’s a few years since you posted this but I have the same problem after filling the MyCloud NAS I use for backups and now I can’t access any files to delete some of them. Did you ever find a solution for this problem?