MyCloud Never Again

I’m sure there are those who have had good experiences with WD drives, but after my experience with myCloud I will never buy another WD product.

I bought this drive several years ago, and used it for a few months. It transferred files at a snail’s pace and at times wouldn’t connect at all. It has been sitting in my office for quite some time, and I finally got motivated to try to take all the files off the drive - mainly prodded by the emails I keep getting telling me some support for this drive will end soon. Theoretically even without the cloud support the drive should still work on my local network or direct to my Mac, but it is so temperamental that if I get the files off I will take great pleasure in smashing the drive to pieces.

I have spent a good chunk of the last couple of days chatting with “support” in who knows what country. They certainly are not in the US, but WD Americanizes the names of their support staff so you think they are speaking the same language, but they aren’t, which makes the support a little more challenging.

Of the three people I worked with, not one could figure out my issues as to why my drive wouldn’t connect. The 2nd person had me do a 40-second reset to wipe most of the settings, and that seemed to help a little, but I still couldn’t;t connect - I got closer but not a full connection. Then finally after more tinkering I connected and got about 20 minutes of file transfers before it just disconnected itself, and now nothing I try will get it to reconnect.

Oddly enough, the file transfers were done AFTER talking with the 3rd person who told me they tried everything and the drive was defective. It may be on the way out, but if I was able to transfer some files before it disconnected it certainly isn’t DOA like she said.

I guess I have to do another 40-second reset - I’m exhausted from what should be a simple transfer of data.

1 Like


More information is needed to asscess what the problem may be.
What specific My Cloud model do you have?
Do you have a My Cloud or a My Cloud Home? They are not the same or even similar devices.
What firmware version is the My Cloud unit running? Firmware version can be found using the My Cloud Dashboard.
Is the My Cloud connected using Ethernet to the local network router? And is that router gigabit capable?
Is the computer you were using to copy the data to or from the My Cloud wireless or wired (Ethernet)?

Generally slow copying can be traced back to a few things. Generally it is using Wireless connection somewhere in the copy chain that is the cause. When ever possible connect the My Cloud to a Gigabit capable router or switch and connect the computer with a Gigabit Ethernet networking port to that same router. Other factors for slow file transfers include the size and amount of files being backed up. also a factor is the device the files are being copied to. Slow hard drive performance also plays a part.


This is a 1st gen myCloud, running firmware 04.05.00-342. The mycloud is connected directly to gigabit capable router via ethernet. The computer is a wireless connection.

I think I have found my best path. Once I got it up and running and connected again I set up FTP through Filezilla and now the files are quickly transferring over to my Mac. No more lag and as long as I stay connected I think I will have everything I need off the drive in fairly short order.

I’ve never had speed issues transferring files over my local network. Regularly get ~100MBps transfer rate on my gen1 mycloud, gen 2 mycloud and DS118/218 synologys. Sounds like a network issue (maybe a slow/noisy wireless connection)? Unfortunately I know nothing about MACs so can’t help any further.

I agree. I had more troubles (and still have) then benefits.
I’ll change NAS as soon as I’m able