MyCloud Mirror FTP / Webdav Access

After returning the nightmare that was the original MyCloud device, I decided to take a chance on the MyCloud Mirror.  I have been quite happy with this since getting it setup.  I’m not networking genius, but I was able to successfully assign the static IP and port forwarding in my Airport Extreme.  I can successfully access the dashboard from my LAN and also WAN.  I am trying to get the Webdav and FTP setup… but am running into trouble.  I have set the port in both Airport Extreme and also in the MC Mirror Dashboard (Settings > Network > Port Forwarding).  I can scan the ports and see them as open, but I can sometimes access the FTP over LAN, but neither is working when attempting over WAN.  

When I open up the dashboard, I see this… any ideas?  

AirPort Extreme. IIRC, does not support UPnP, so port forwarding configuration from within the Cloud will not work. You just configure the Airport manually.

Thanks for the reply…  I’ve actually already configured these directly in the Airport also to mirror the setting/ports from the cloud dashboard.  So… I should be able to ignore the port forwarding section of the dashboard and solely configure/troubleshoot through the Airport Utility?

I’m still at the same spot, but that’s at least one variable I can eliminate in trying to get this to work…  

For FTP to work over WAN, make sure you set the external IP field (to whatever is your real WAN IP) from the FTP settings when configuring from the dashboard. There is a bug in the My Cloud EX2’s firmware that doesn’t let it be set…not sure if that bug is also there in the My Cloud Mirror firmware or not.

Assuming that the Mirror doesn’t have that bug and you are in fact able to set the external IP, then FTP should work. I am a bit unclear why you are picking the port 8021 for the public TCP port for FTP - why not port 21?

I’m curious to see screenshots of your FTP configuration from the Mirror’s dashboard settings.

hmm… when I try to set the external IP in the Dashboard FTP settings, I get an error when I use the ‘Get IP’ button and it will not save if I try to hardcode it… so I guess this firmware has the bug also.  I set all FTP ports to 21, but no luck their either.

On the WebDAV part… i flipped the toggle to ‘ON’ in the dashboard, set the Port Forwarding in the Dashboard and also in the my Airport Extreme… but stil no go on that either.

nicholastrausch wrote:

hmm… when I try to set the external IP in the Dashboard FTP settings, I get an error when I use the ‘Get IP’ button and it will not save if I try to hardcode it… so I guess this firmware has the bug also.  I set all FTP ports to 21, but no luck their either.

 

I reported this bug to WD tech support and after waiting for awhile, they acknowledged the bug and told me it will get fixed in the next firmware release but have not given any date for the release. TStill waitng for this bug to be fixed. Not too many people use ftp from outside (this bug only affects ftp from outside, internal ftp is unaffected) and therefore WD has so far gotten away without fixing it for so long. I strongly suspect the EX4 firmware has the same bug also, since the EX2/EX4/Mirror share the same codebase. Anyway, I encourage you to open a ticket with WD Tech Support and report this bug for the Mirror as well. Otherwise they might fix it for EX2 but not for Mirror.

As long as this bug exists, it is impossible to get FTP to work from outside…UNLESS you do a simple manual workaround (see below). And make sure you don’t set any port forwarding on the Mirror itself but do set port forwarding on your router for the Mirror’s IP on TCP port 21.

Do the following steps for the manual workaround ONLY if you feel comfy using a SSH connection to the Mirror, then first enable SSH Access from the dashboard (Settings -> Network -> SSH). Then:

  1. Connect to the IP of the Mirror using an SSH client like the free PuTTY tool

  2. cd /usr/local/config

  3. Backup the config.xml file preserving permissions and timestamps (so that it can be brought backeasily):

    cp -p config.xml config.xml.bak
4. Edit config.xml in vi - scroll down to near the end of the file but not at the very end…just a little before the end, look for the tagged section

  1. Inside section, look for the  tag

  2. Replace 0.0.0.0 (or if it’s blank just insert) with your external IP

  3. Once the external IP value inside the  is added, save and exit the file

  4. Reboot the Mirror from the dashboard

  5. After reboot, the dashboard config screen will still not reflect this changed external IP but ft will work now from outside.

  6. Be aware, if you make this change, ftp will work from outside but won’t work from inside the local network…but if you leave that setting blank (i.e. ) then ftp will work internally but not from outside the network.

  7. If you need to return to the original config.xml file simply replace the edited file with the config.xml.bak file:

       mv config.xml.bak config.xml

Good luck!

thanks for the info.  debating on whether I need it bad enough to mess with the SSH route.  i will definitely open a ticket so that hopefully the Mirror also gets fixed.

The ftp hack outlined above is quite simple to do, but I understand the trepidation if you never have delved into a command line environment like Linux or Unix. I have pretty much detailed all the steps…and they are really simple, but perhaps the only tricky part for you, if you are unfamiliar with vi, is to make the small edit to the file. You may need to google couple vi shortcut keys for navigation (arrows and page up/down does work) and for editing. That would be the only minor things you’ll need to lookup. Rest is all there.

If my previous (or this) answer helped, please feel free to click on the little star on the left of a post underneath my username to give me a kudo (thanks).