MyCloud Home e KODI (LibreELEC) - no access!

#1

Buongiorno al forum
A casa di mio nipote circa un mese fa ho montato un MCH, connesso via cavo ethernet al Router, creando nella cartella Public una sottocartella contentente la sua libreria multimediale. Unitamente al MCH, abbiamo installato un Raspberry PI3, con a bordo la distribuzione LibreELEC (Kody Krypton 17.4). Anche il raspino collegato via cavo al router. Siamo riusciti velocemente a configurare la libreria, in quanto il MCH (la sua parte “public” ovviamente") veniva visto addirittura come una cartella sotto WORKGROUP aprendo “Condivisione Windows (SMB)”. Avevo provato anche il metodo “Add Network Location”, che prevede di inserire l’IP address della LAN e la cartella “Public” sharata e funzionava alla grande.
Oggi abbiamo provato, avendo spostato il Raspy in camera collegandolo via HDMI ad un’altra TV e connettendosi alla rete via Wi-FI), a collegare un Media Player Wetek Play2, con a bordo la stessa versione di LibreELEC/Kodi (ovviamente quella specifica per il processore ARM, non quella per il Raspy…). Configuriamo tutto, lingua, rete, ecc.ecc… Al momento di andare a “pescare” i contenuti dal MCH… nisba. La “Condivisione Windows (SMB)” sotto il nodo “WORKGROUP” era desolatamente vuota (sul Raspy apparivano il MCH, il Router e i due PC Windows10 di casa…). Provo allora con il metodo “manuale” di “Aggiungi locazione di rete”, metto IP address del MCH, folder “public”… ma la richiesta va in timeout.
Per sicurezza, da uno dei due PC Windows 10, aprendo Windows File Explorer e digitando \192.168.1xx\public… accedo tranquillamente alla cartella e vedo i suoi contenuti.

Il sw (LibreELEC) è lo stesso, la rete idem. Cosa può esserci di diverso nell’accesso al MCH\public ?
Devo mettere per caso una specifica username e pwd (sul Raspy ho lasciato vuoti i due campi). Se si , quali? Avevo letto che il MCH accetta fino a 5 connessioni Samba contemporanee, quindi non credo sia nemmeno quello il problema.

Qualche idea?
grazie
Andrea

#2

Ciao Andrea,

Ho letto e riletto TUTTO il tuo post per poter capire tutto l’iter e quello che avete fatto complimenti per le tue conoscenze su Kodi e Raspberry PI3 :grinning:

(Premetto di usare la distro Leia 18.2 e non la Krypton, ma non è importante).

Dunque, mi sa di aver capito il problema. Il punto più importante da te descritto (da quello che capisco) e quoto:

Oggi abbiamo provato, avendo spostato il Raspy in camera collegandolo via HDMI ad un’altra TV e connettendosi alla rete via Wi-FI)

Eccoci qua. Il My Cloud Home ha bisogno di una connessione internet cablata, mi sa che non funziona con una connessione Wifi sopratutto se stiamo parlando con un accesso via Raspberry P3. Potrei anche sbagliarmi ma è la prima cosa che mi è venuta in mente.

Se digiti l’IP da entrambi i pc di casa \192.168.1XX\public la cartella è accessibile?

Su entrambi i computer Windows 10, SMB1.0/CIFS è attivato?

#3

No no, quello ad avere problemi è il media player collegato al router con cavo Ethernet ( al quale prima era connesso il raspy). Il raspy, spostandolo e collegandoli wireless funziona benissimo.Al WD non importa se ci accedi da un device wireless o cablato… è il router il problema. Ed infatti, riavviandolo un paio di volte , ieri è andato tutto a posto! È il router technicolor di Fastweb che è una ciofeca tremenda.