MyCloud Home as Sonos NAS stopped working

Looks like the latest firmware release for MyCloud Home (8.12.0-178, released on 14 Nov 2022) has stopped me from using my device as a NAS for my Sonos system. Something to do with SMB protocols maybe? Is anyone else experiencing the same problem? Found a solution yet?

I have all my music stored in the “public” drive and can still see it using a mapped drive on my PC. The public folder is added as Music Folder in my Sonos S1 system and had been working perfectly until recently.

1 Like

Exactly the same problem here since the update

Are you SONOS on S1 or S2?

It appears that only S2 support more recent (and safer) versions of SMB… maybe the newest firmware finally removed SMB v1.

I’ve had terrible problems since the last update(s). I have used MyCloud Home as a Music Server for 1-2 years now. Worked mostly great until this update.

The last month has been countless “logins”. Sometimes the app (tablet/phone) will just sit there. Lots of times, I cannot even use the product.

What a lousy update!

I’m forced to use S1 unless I want to ditch all my perfectly serviceable (until now!) legacy sonos players.

I’m sure you’re right about the latest firmware ditching SMB v1 so I am currently scratching my head to think of any other ways to get the system working again using what I’ve got.

Exactly the same problem here.
I can’t get the “My Cloud Home” Music Service to work either: I add the service, follow through to where I authorise Sonos to access my “My Cloud Home account”, but no folders/files appear.
Anyone have any luck with this?

I found an article describing how to use OneDrive
OneDrive for Sonos
and I have copies of our music there too so I’ve got a solution, hopefully temporary, to continuing to use our Sonos 1 products but it isn’t as good as what I had a week ago - no search, etc.

Does anyone have an email address to contact WD directly (or is that a naive question?) ?

Anyone had any luck with a solution to fix this pronlem ?

No, and I suspect I’m not going to be able to. After all I have read about SMB v1, there’s no way WD will backtrack to re-enable it, and it doesn’t look like the legacy Sonos equipment is capable of supporting later SMB versions. So, it’s a case of finding a suitable workaround.

I’m not going to invest a different NAS because it’s clear the writing is on the wall to do away with SMB v1 altogether in the near future.

I’m not going to upgrade my legacy Sonos system, even with a 30% discount.

So, for the time being I have mounted my backup drive (a WD My Passport Ultra) on my Windows 11 laptop, added it as a Music Library and just turn the PC on anytime I want to play music. Not ideal, but it will keep me going until the next upgrade bricks that option!

1 Like

Having the same problem I was going through all WD messages.
a) Sonos S1 needs SMBv1
b) My Cloud Home SW version 8.12.0-178 supports SMBv1, but need to be turned on.
c) Therefore it needs to be connected in the port forward mode. With a PC in the same local network it should be possible using the “local app” to activate the SMBv1. So far to the theory. Unfortunately my Harddisk is in the so called Relay mode. To use the Harddisk in the port forward mode upnp needs to be active on the router.
Having done all this I already tried several times to restart the disk and to access it by the local app on the same “local network” but it’s always in the relay mode. No glue how to achieve to change it. Reset > 60 sec to set the firmware back? But then all data is also gone:-)

Minimum is SMB v2

Oops. Other alternative I tried is to add my cloud as a service in Sonos as e.g. TuneIn. It worked but you need to move the music files from public into a local folder.

Is there anyway to go back to a firmware before 8.12.0-178

Yes but not officially supported, one could clone a disk image from an earlier version such as 7.16.0-220 to the MCH but 99% of the home users are not going to do that when the new firmware is a lot more secured, disk transfer speed a lot faster and operable without internet access than the old.

One is better off just enabling SMB v1 support for Windows and support the old Sonos v1 that way until it breaks or becomes really dated.

Indeed, but you wrote that the actual firmware only supports minimum SMBv2!

That quote was meant to say to run Windows from any cheap PC or laptop and turn on the Windows SMB v1 support and use it as a file server for the Sonos. It wasn’t meant to say one could use the MCH as a SMB v1 server with the new firmware.

For completeness of discussion, one could back up the first 23 partitions of a MCH from an earlier firmware and use that as recovery. For example, the instruction can be found here (but again 99% of MCH home owners are never going to do this)

I have now managed to make the SONOS “My Cloud Home” Music Service work, accessing the music I had stored on the drive (\\Public) except that when I add a new folder with extra music in it doesn’t show up on the SONOS system (but I can see it if I go to the drive via Windows Explorer).
Any suggestions?
BTW this isn’t as good an interface as attaching the Public folders as a music folder to SONOS

I have read all of these posts and at least realise that I am not the only one having problems with Sonos and MY Cloud. I can use the MY Cloud app to play music through Sonos , but this app is not like using Sonos Music Library. I think the problem with this was the smb version previously.

I was hoping this might now work but cannot remember how to write the path name into the library. Have researched this and cannot see how to do this. Well I know where to write the path name but either do not know the correct path name or it just can’t access it.

The other problem I now have is that I cannot get Stream magic app to find the My Cloud to use with my new streamer. Fed up of WD My Cloud and wish I had never bought it.

Thinking about spending on a different NAS Synology , but don’t want to end up in the same position. Was considering trialling ROON but cannot see it working . Any suggestions?

1 Like