MyCloud EX2 Ultra will Not Upgrade to OS5

I have a MyCloud EX2 Ultra that I am trying to upgrade to OS5. Current firmware is 2.41.116 and I see the Upgrade option/button from the admin WebGui. When I click the button I run through all the questions and when I clock the upgrade now nothing happens. The screen never changes, it is like it did not take my click. I even tried to update it via file upload and still nothing. Am I missing something?

Thanks in advance for any help.

Upgrade at your own risk - the new OS is not good - mine is locking down every other day, and the indexing goes forever. I wished I could downgrade mine to be stable. I’m strongly considering buying a decent hardware now giving this OS is very unreliable, and WD is doing nothing to fix it.

2 Likes

Thanks for the replies guys. I did try to reboot (both soft and hard reboot) and no luck. When I click “Start Upgrade” nothing happens. First thing I am going to do is copy my data off to my Mac just in case I hose this.

I did not realize there were so many issues with OS5. I will look at more of the posts on here to see what is going on. I am not doing anything “complicated” with mine, just want to store my pics, videos and docs somewhere other than my Mac.

@MIKEAP Can you get the My Cloud Logs .

Please create a case and share the logs on that case

I did open a ticket: 210105-002746. I tried to save the logs and it never asked me to save them. I did notice that logs were not enabled in the Admin GUI, I just enabled them and will try to get then again.

I have an EX2 Ultra as well, I downloaded the firmware and then did the update from a file instead of remotely… It updated no issue…

But if I may… DONT UPDATE… Since I updated I have lost my ability to remotely log in…

1 Like

My WD4100 is locking every 3 days or so. Need to turn it off by unplugging from the power supply. - OS 5 is a piece of s… And WD does not care. Be aware that the way that WD has a direct link to your data now. I did not read their disclaimer notes, but I’m pretty much sure they say they can download anything they want from your hard drive. Or delete your day for what I’m concerned. You can write anything you want on this blog as WD does not care to read any notes anyway.

1 Like

Just wanted to update you guys. Working with support they had my connect my EX2 directly to my PC via the ethernet connection, then try to upgrade it via file. That worked perfectly and I am now running OS5 and are not having any issues. I can access it via my iPhone, iPad and PC from inside my network and outside. We will see if I run into any issues. Still dont get why I could not upgrade while it was on my network.