MyCloud Ex2 Ultra - RAID Roaming not working after removing and returning original drives

Running out of storage space, I went for an upgrade from 2x3TB in RAID1 to 2x12TB in RAID1.
First I have inserted one of the new 12TB drives and let the NAS rebuild from the remaining original 3TB drive.
Then did the same with the 2nd 12TB and let the NAS rebuild from the 1st new 12TB.

To my surprise I ended up with only 3TB in RAID1 and was trying to figure out, how to expand the size of the partition to use out the whole new capacity (I did not want separate partitions, which was the only option the NAS was offering me). With no luck I tried to switch back to my original 3TB drives but those refuse to work in the NAS unit. There was no roaming notification, nor anything else.
The “Storage dashboard” RAID Health states: No Configured Volumes.
The disks in Disk Status though both are Healthy.

As I was not expecting any issues switching back to the original healthy drives, I executed quick formatting from the NAS Setup on the new 12TB drives (trying to get them back to the original state and full capacity to move over the data old school via wire). Naive, even stupid perhaps, I know. :frowning:

Does anyone, please, has any advice on how to resolve this?

A few tips from someone who has not done this :slight_smile:

  • The drives are not interchangable. If you mix up the drives (i.e. put the drive from slot one into slot two); you will get the results you saw.

  • When installing NEW LARGER drives using the “raid rebuild” method you used; you naturally WILL get a raid the size of the raid you started with. At the end of the process, you need to go into the “Raid configuration” menu and look for a “Raid Expand” button.

  • What would I do in your shoes? I would put the new drives into NAS; and setup as an empty 12TB drive. . . .then copy your old drives over by wire. As an alternative; I might try to reinsert the 3TB drives (swapping the positions) and see if the old volume is recognized.

  • What would I do in my shoes? I have more money than sense. When upgrading the NAS size; I bought another NAS box (the box cost is low relative to the cost of the drives in my mind) (I AM NOT CLAIMING THIS AS A COMMON PATH FOR NORMAL PEOPLE)

1 Like

Switching positions of the original drives was one thing I was afraid to try. And it just worked! :blush: And even though the RAID Health status is Degraded, I can see my files!

I cannot see the manual rebuild there, only Auto, which I am afraid now to enable.

The Disk Status also keeps working on the System Disks status without showing any results.

Thank you so much anyway!

I will try to transfer the files now to an external unit. Although I am short of one NAS unit to do that the way you’ve suggested.

I cannot see my old files anywhere else then via the NAS unit. So if I want to do the wired copy, I would need another unit to work with the new disks. Which brings us to your last point. Do you have any suggestions on what NAS unit to go with or even point me kindly in some directions?

Again, thanks a lot! <3


OK - - -you mentioned “fear”.
I understand “fear” when the consequence is total data loss.
I am not sure what the “Raid degraded” means. I would try rebooting. . . and see if it goes away.
The degraded probably relates to the Disk Status check, which might take time.

I strongly recommend getting an external 4TB external HDD - - → And copy all the data off the NAS.
You want that anyway; since the NAS box is a “common mode” source of failure (Think: FIRE. Think USER ERROR)

With the Data on the HDD, I would then swap the 3tb to 12 TB drives in the NAS; then copy the data from the HDD to the NAS

As for another NAS: Cheapest alternative is to get another Ultra EX2 (Diskless).
If you want an upgrade: I would go for “Brand S***ology”. The 220+ has better hardware; but costs a bit more. Software is VERY different (so there will be a learning curve) and has some very cool features. (note: You cannot migrate the Raid volume between brands)