MyCloud 4TB won't go into Energy saving mode

Ah, it could be the restsdk-serverd problem:

MYCLOUD:/var/log# tail user.log
2015-12-14T19:27:04.616390+01:00 di=jHARWTUXpZ notice restsdk[6033]: watch.go:109: Stat(), error: stat /tmp/dynamicconfig.ini: no such file or directory
2015-12-14T19:27:14.749208+01:00 di=jHARWTUXpZ notice restsdk[6033]: watch.go:109: Stat(), error: stat /tmp/dynamicconfig.ini: no such file or directory
2015-12-14T19:27:24.829630+01:00 di=jHARWTUXpZ notice restsdk[6033]: watch.go:109: Stat(), error: stat /tmp/dynamicconfig.ini: no such file or directory
2015-12-14T19:27:34.907814+01:00 di=jHARWTUXpZ notice restsdk[6033]: watch.go:109: Stat(), error: stat /tmp/dynamicconfig.ini: no such file or directory
2015-12-14T19:27:44.910244+01:00 di=jHARWTUXpZ notice restsdk[6033]: watch.go:109: Stat(), error: stat /tmp/dynamicconfig.ini: no such file or directory
2015-12-14T19:27:54.911815+01:00 di=jHARWTUXpZ notice restsdk[6033]: watch.go:109: Stat(), error: stat /tmp/dynamicconfig.ini: no such file or directory
2015-12-14T19:28:04.913496+01:00 di=jHARWTUXpZ notice restsdk[6033]: watch.go:109: Stat(), error: stat /tmp/dynamicconfig.ini: no such file or directory
2015-12-14T19:28:14.915555+01:00 di=jHARWTUXpZ notice restsdk[6033]: watch.go:109: Stat(), error: stat /tmp/dynamicconfig.ini: no such file or directory
2015-12-14T19:28:24.917245+01:00 di=jHARWTUXpZ notice restsdk[6033]: watch.go:109: Stat(), error: stat /tmp/dynamicconfig.ini: no such file or directory
2015-12-14T19:28:34.919006+01:00 di=jHARWTUXpZ notice restsdk[6033]: watch.go:109: Stat(), error: stat /tmp/dynamicconfig.ini: no such file or directory
MYCLOUD:/var/log#

MYCLOUD:/etc# ps -ax | grep restsdk
warning: bad ps syntax, perhaps a bogus '-'?
See http://gitorious.org/procps/procps/blobs/master/Documentation/FAQ
 6032 ?        S      0:00 /bin/sh /etc/rc2.d/S20restsdk-serverd start
 6033 ?        Sl     0:01 /usr/local/restsdk/restsdk-server -device-kind sequoia
 9161 pts/0    S+     0:00 grep restsdk
MYCLOUD:/etc#

What is the rest of the message? As you can see it is writing to the log every ten seconds.

RAC

PS I don’t see that message because I have stopped restsdk-serverd.

You mean the rest of the log-file? This is all he does 75% of the entries

What I mean is what is after the 2015-12-14T19:27:04.616390+01:00 di=jHARWTUXpZ notice restsdk[6033]: watch.go:109: Stat(
Stat( what?

The simple thing is to stop the restsdk-serverd process.

RAC

[quote=“Yaerox, post:22, topic:142197”]
), error: stat /tmp/dynamicconfig.ini: no such file or directory
[/quote]I did this post in code-tags. I can scroll tho. Anyway what you’re missing is:

), error: stat /tmp/dynamicconfig.ini: no such file or directory.

Btw. I often read about doing system factory reset will help. I did this, same FIrmware version as mentioned in my first post. still the same problem. Won’t go into sleep. My /var/log/user.log:

2015-12-14T21:36:40.638688+01:00 di=jHARWTUXpZ notice restsdk[6779]: watch.go:109: Stat(), error: stat /tmp/dynamicconfig.ini: no such file or directory

For now I opened a case in WD support because if this is a known Problem, I wanna hear it from a support … if they won’t help I’d try stopping this process

To me factory reset is a catch all when they don’t know what else to do. It’s almost like you taking your car to the repair shop and they say buy a new car. If I remember this error is caused when you have remote access disabled. If you enable remote access I think this error will go away. I’ve talked to WD support about this problem months ago. No response. Support is not going to tell you to stop this process. When asked ,support say that the disk drive is designed to run 24/7 don’t worry about it.

RAC

What happens if you just create an empty /tmp/dynamicconfig.ini file? e.g. using

touch /tmp/dynamicconfig.ini

I have no idea. But would think that it would try to read the file and get some kind of error. This should be an easy problem to fix. But WD seems to have other things to do rather than fix problems.

RAC

1 Like

Well, I can try this. In around 3 to 3,5 Hours I’ll be home and able to check this out.

Just created the file to see if this will fix anything. But I had an idea … well I got a Windows 10 PC. I’m actual doing tests while my PC is online but not directly accessing the NAS by a mapped network drive or something like this. But whenever I open my WIndows Explorer, my NAS is listed @Network. Does your NAS go into hdd-standby even if your PC is o nline but not directly accessing? Just a thought.

Edit: So Phone Support couldn’t really help. His idea was my Anti-Virus, but even if all PCs are off the problem is still here. I’m going to full restore my NAS tomorrow. Quick restore with deleting data didn’t helped. Otherway I’ll request an RMA.

RMA will replace your shiny new machine with a refurbished unit…

And probably still have the firmware problem…

Did you try enabling cloud access?
Did you try stopping the restsdk-serverd daemon?

I know RMA probably won’t fix this. But if I pay 200€ for a NAS, I won’t have to spent 3 weeks of m time to get this running.

I didn’t tried enabling Cloud-Access or stopping Process yet. I’m actual planning on doing a full factory reset, and try if the HDD is going into standby on 100% default settings. CLoud Access is enables by default, just simply not configured. Do you think I have to configure Cloud Access too? If this won’t fix the problem, I stop the process and finally if this won’t help I’ll return this product and get another NAS.

Full factory reset will not fix the problem. The problem is in the firmware. There are at least two or more issues that cause the My Cloud to not sleep. Both of which can be corrected. With the
corrections my My Cloud sleeps 495 hours out of 558 total hours up time.

RAC

I really appreciate your help, and like I said, if the factory reset won’t fix it, I’d like to try what you said with stopping this restsdk-process. Would you give me a tip about the second issue you know? Or did I overread it?

If when you are SSH’d into the My Cloud do a mount command. It will list all of the partitions and how and where they are mounted. If you look at any of the sd4 partitions you will see that they have two options noatime and nodiratime. But the / partition does not have these two options.
This means that any time a file on the root partition is accessed the inode for that file will have its atime updated. When this happens a kjournal entry is written to the disk. These journal entries get written several times a minute.
On my system i do the following command:
mount -o remount,noatime,nodiratime /dev/root /

I’ve spent a lot of time looking into the sleep issue.

RAC

I really do appreciate your help sir, and I’m going to look-up all that stuff after work, as soon as I’m home.

So I’m first going on my Cloud using SSH and stop this restsdk process (/etc/init.d/restsdk-serverd stop). Then I watch out my mounts, and do your statement or going save and posting my output first.

Btw. the full factory reset took around 15-16 hours, and didn’t helped at all. The full default settings are still not working.

Edit: Couldn’t work on this yesterday. Today after WOrk I’ll do what I just said above. Thanks everyone.

So I stopped the restsdk-serverd process and I remounted the /dev/root /. It seems to work now. I tried alot of stuff using my TV/HD Receiver to play Videos etc. and decided to use my WD TV for this. So now everthing seems to work brilliant.

I setted up the NAS the way I want to, and I’ll check before going to bed if the NAS still goes into sleep. I did some tests already before I connected all other devices in my network, but I’ll check this just to make sure everything is fine now.

Anyway, I really really want to thank you rac8006.

One more question. In case I need to shutdown/reboot my cloud, I need to stop the process, OK. But do I have to remount every time too?

And is there some way or some startup script where I can change the code that this process won’t even get started?

Yes you have to remount also. You can put some code in the /etc/rc2.d/S98user-start file.
Put in this file those things that you enter from the keyboard on reboot.
as an example put these two lines in the file

/etc/rc2.d/S20restsdk-serverd stop
mount -o remount,noatime,nodiratime /dev/root /

RAC

1 Like

Tested it some days now works like a charm. I didn’t edited this startup script yet, but I’ll do this someday.