MyCloud 4TB won't go into Energy saving mode

All that just to get it to SLEEP? I guess Ibhave no hope of fixing the endless list of problems with my new one. Why didnt they put a (usable) USB port on it. UNIVERSAL Signal Bay, except when its on a WD…

USB = Universal Serial Bus. As anyone who has worked in IT for 25 years would know. They’d also know that you wouldn’t have any luck accessing a PC’s HDD via any of its USB ports…

Signal / serial who the heck cares it doesnt WORK in Any Universal Way on THIS DEVICE. AND One can almost Always Access a hard drive via its USB sarcastic JERK like with a MyBook or any external USB Drive just not with THIS one…,

Except the My Cloud is not an external HDD. It is a NAS, which is a USB host, not a client.

It seems like the My Cloud does not meet your needs. I would recommend selling it and moving on.

1 Like

Even it its not regarding this topic and you should maybe open a new thread, whats the matter. Mine USB works like a charm.

I’ve had my 4TB srive for almost a year with media serving, iTunes and remote access on the entire time. It used to go into sleep mode just fine but it hasn’t for the last couple of weeks. The LED is steady blue and I can feel the drive spinning in the case though I don’t hear any actual drive activity unless I’m accessing the drive. I’ve tried resetting it multiple times but it still won’t go into sleep. Any thoughts?

Simply check the process and mountng options just like described above from rac.Maybe you just got a new firmware update.

Hello my friend. Having the same problem and only now saw this thread.

How do I enter these commands? Where?

I have no open interface to write commands in the dashboard and it’s the only interface I have with the device.

Thanks :slight_smile:


You need to enable ssh in the dashboard. Then you can ssh into the My Cloud and enter the commands.

Thanks :slight_smile:
I use WinSCP, it allows me to login, view files and edit them but it wont allow me to execute a command.
Or does it?


Not sure . I use putty.


I executed the following in the command terminal:

/etc/rc2.d/S20restsdk-serverd stop
mount -o remount,noatime,nodiratime /dev/root /

and nothing changed, green LED is still flashing and the drive still wont go into sleep.

I tried editing the files as you instructed but in the /etc/rc2.d/ directory the S98user-start file is marked in red and when I try to edit it, it says file not found. An ideas please?

It does allow you to execute commands. Click the icon highlighted in the graphic.

The green led on the back does not indicate that the disk is in standby. The front
led will go from solid blue to almost off when it is in standby mode. Also the disk
will wake up at midnight, 3:00AM 8:00AM 4:00 PM and 8:00PM
When the disk wakes up it will take 10 minutes of no disk activity before it will
enter standby mode.

Do a forum search for “sleep” if you haven’t done so already. LOTS of discussion on this particular issue of the single bay My Cloud not entering or staying in sleep mode.

For example on my first gen single bay My Cloud this is my /etc/rc2.d/S98user-start that I used for a period of time.

# User startup script
# should run automatically after every reboot, and be unaltered by firmware upgrades
# so should sort out the mess caused by firmware upgrades

# stop and disable indexing services (just stopping the service not disable)
/etc/init.d/wdmcserverd stop
/etc/init.d/wdphotodbmergerd stop
# update-rc.d wdmcserverd disable
# update-rc.d wdphotodbmergerd disable

# stop RESTSDK server daemon
#      for OS3 only
/etc/rc2.d/S20restsdk-serverd stop

# stop unwanted wakeups
mount -o remount,noatime,nodiratime /dev/root /

My single bay first gen sleeps erratically even with these changes. Some devices on the local network tend to keep the device from sleeping apparently. Still though, get MUCH better sleep time with the above script then without it. Without that script my single bay never sleeps more than 6 seconds or so before it wakes up (probably because of the stupid script.

I’ve run into a new condition that keeps the disk from sleeping. If I open windows explorer
while I have mapped My Cloud drives. One of my My Clouds will not go into standby. A network
trace shows that the windows system is issuing a SMB2 QFID request every 30 seconds or so.
Don’t have a lot of information about this condition yet. This QFID request has something to do with
getting size of the share or something like that.
Funny thing is that not all My Clouds wake up during this condition. My Gen1 My Cloud seems to sleep thru this process. The gen2 My Clouds which have a newer version of samba seem to be affected by this condition.

Yes, having a mapped Share/My Cloud drive will cause wakeups. Had that problem on my first gen where every time I brought a PC out of sleep or booted the PC it would wake up the My Cloud, then keep it awake. Only fix was to not map Shares. :frowning:

Then there is the editing of the montinaro (spelling?) file. Frustrating we customers have to edit files and stop WD services just to get the hard drive to spin down and sleep when not in use.


thank you so much. the drive simply wont go to sleep, I can always hear and feel the disks spinning and I’m sick of it. How long can it live like that? And I only get data from it an hour a day maybe…

I should have gone with an external usb drive and connected it to the usb input of my router and save all the hassle.

Yes it is Frustrating. I find it interesting that only the gen2 My Clouds stay awake when
a a drive is mapped. Not sure why windows needs to get the share size every 30 seconds.
Also sometimes even one of the gen2 My Clouds will sleep thru the 30 second request while
the other gen2 won’t sleep.
The way WD wrote the software is very amateurish. They scan the disk checking every file
looking for new files. When there is a function in Linux to tell an application when a new file is
created. Then they go to a busybox system which makes it difficult to do most Linux commands.
Most of the code on both My Clouds is several years old. Like samba is not supported in the real world.
They release the GPL source. But when you compile from the GPL source. You don’t get the
same application with the same compile time options. Most likely because they didn’t but from the same GPL.
I guess that is enough venting.

The gen1 is difficult to troubleshoot why the disk won’t sleep. In your case
I would turn off as many feature in the dashboard that you can get along without.
Keep SSH enabled. Start experimenting with which processes you can live with out.
The following script will try to tell you which files are being accessed. I usually run it with the following command.
bash 60

This will check the /proc/diskstats file every 60 seconds. If a read or write has occured
it will scan the filesystem looking for the file that was changed in the previous 60 seconds.
This might help determine why your disk does not sleep.
Device=(“sda4” “md1”)
sda=(" " " " " " " " " " " " " " " " );
function test () {
if [ “$1” != “$2” ]; then
da=date +%k-%M-%S
let a=ior_sda-ior_sdaold
let b=iow_sda-iow_sdaold
if [ $4 -ne 1 ]; then
echo -n $da " "
printf “%4s %4s %4s " $3 $a $b
A=cat /proc/cmdline | awk -F= 'BEGIN{RS=" "}{ if ($1=="root") print $2 }'
while :; do
for x in “${Device[@]}”
sda[$i]=awk -v disk="$x" '{if ($3==disk) printf "%s-%s",$10,$6}' /proc/diskstats
let B=i=0
for x in “${Device[@]}”
test “${sda[$i]}” “${sdb[$i]}” $x $B
if [ $B -eq 1 ]; then
find /bin /etc /boot /lib /usr /CacheVolume /DataVolume /nfs/SmartWare /nfs/TimeMachineBackup -cmin -1
sleep 4