MyCloud 4TB won't go into Energy saving mode

Hi rac8006

WDMyCloud:/DataVolume/shares/Public# bash 60 line 3: $‘\r’: command not found line 4: syntax error near unexpected token $'{\r'' ' line 4: function test () {

I want to know the sleep issue but I find this error when I run the script. Would you advise?


Which device do you have Gen1 or Gen2?

Mine is Gen1 4.05.00-342. I spent more than 3 days on the sleep issue. Tried all methods after searching the nearly all posts. Still cannot solve the issue. Sleep around 10 minutes then wake up again. I think Samba is the main issue.

Would you advise whether I downgrade the firmware to which version or do other steps as well? My objective is to sleep around 80% of time.


Cannot speak for others but I was never able to get my first gen v4.x My Cloud to sleep properly. It was always waking up to perform various tasks even though the scanning was disabled via firmware tweaks. It ended up being a combination problem. Samba is a partial cause in addition to how the firmware is coded. Any time I brought a Windows PC out of sleep, or booted it, it would wake up the My Cloud. Best guess is Samba traffic is triggering the My Cloud to wake up.

Then there is the firmware itself. Short of neutering the entire firmware which disables most if not all features/options, it will periodically wake up to perform actions. One way to test is to put the My cloud on a network all by itself and check how often it sleeps. The second you enable options like remote access, iTunes/Twonky, and other features the My Cloud won’t stay asleep for long periods of time (at least in my experience).

I spend many wasted hours and made many past posts trying to fix the sleep issue. In the end I gave up. Did the basic firmware tweaks and just live with the fact it doesn’t sleep due to crappy firmware and the Samba issue. YMMV

Did you cut and paste from the script above? If you did it has incorrect characters when copied.
If you are familiar with vi or nano you should be able to edit out the bad characters.
In my looking into the sleep issue. I found several issues with samba and other OS functions that
would effect the sleep issue.

I already take into account rac8006 and many people’s advice in this forum and edit the S98user-start file as follows


User startup script

should run automatically after every reboot, and be unaltered by firmware upgrades

so should sort out the mess caused by firmware upgrades

Move Msg.sock to temporary RAM location

/etc/init.d/samba stop
mount -t tmpfs -o mode=0700,noatime,size=2m tmpfs /etc/samba/msg.sock/
/etc/init.d/samba start

Stop and disable indexing services (just stopping the service not disable)

/etc/init.d/wdmcserverd stop
/etc/init.d/wdphotodbmergerd stop

stop RESTSDK server daemon

for OS3 only

/etc/rc2.d/S03atop stop
/etc/rc2.d/S20nfs-common stop
/etc/rc2.d/S20nfs-kernel-server stop
/etc/rc2.d/S20restsdk-serverd stop
/etc/rc2.d/S20winbind stop
/etc/rc2.d/S50netatalk stop
/etc/rc2.d/S60mDNSResponder stop
/etc/rc2.d/S61upnp_nas stop
/etc/rc2.d/S85twonky stop
/etc/rc2.d/S85wdmcserverd stop
/etc/rc2.d/S86wdphotodbmergerd stop
/etc/rc2.d/S92wdnotifierd stop
/etc/rc2.d/S95wdAutoMount stop

stop unwanted wakeups

mount -o remount,noatime,nodiratime /dev/root /

Stop Cron

/etc/init.d/cron stop

But the sleep effect does not improve much. Therefore, before I give up, I would like to know whether the firmware downgrade would actually help according to your past experience.

I wish I could help. I have not worked on the My Cloud devices for a couple of years.

Downgrading does open up previously patched security vulnerabilities. So you will need to decide if potentially solving or dealing with the sleep mode by rolling back the firmware is worth opening up previously patched security vulnerabilities. Also note that if you use Remote Access (Cloud Access) downgrading may break the ability to access your My Cloud remotely.

Do a search forum search for “sleep” (, and look at the dates of the posts. Try to find the earliest posts to see what firmware version (if listed) people were using. This failure to sleep issue has been around for many years and many past firmware releases. If you do find a prior firmware version that may work one can try to roll back to is.