MyCloud 4Tb - No LAN & Flashing Yellow LED

Thank you for your reply.

My understanding was that doing the 40 second reset would result in ALL data being lost - is this correct? - you seem to suggest that the data was still there after doing your reset procedure.

Can you confirm please? - I have a lot of data on this drive that I can’t afford to lose!

No, not correct. You DO NOT loose any user files/data when performing a 40 second reset via the reset button on the back of the My Cloud. Please see the following WD Support document.

http://support.wdc.com/KnowledgeBase/answer.aspx?ID=13986

Per that document. The 40 Second Reset, also known as System Only Restore, will reset the following:
Admin User Name (default = “admin”)
Admin Password (No password by default)
Device Name (default = “WDMyCloud”)
Remove all Users except Admin
All Share permissions (default = Public)
Automatic Firmware Update (default = off)
Network Mode (default = DHCP)
Remove all Alerts
mycloud.com account association (default = not configured)
Mobile app account association (default = not configured)
WD Sync association (default = not configured)
Backup jobs (default = not configured)
Safepoint jobs (default = not configured)

Per that same document the 4 Second Reset will reset the following:
Admin Password (No password by default)
Network Mode (Default = Dynamic Host Configuration Protocol (DHCP))

Thanks for asking!
I looked up the user manual just to verify myself

Page 64:
System Only: Changes all settings back to the factory default values, makes private shares
public, and returns the administrator password to none. Your content remains untouched
and intact.
Note: You can also do a system restore physically. See “Resetting the My Cloud
Device” on page 90.

Page 91
Resetting with Power Off
At the same time as you plug power into the My Cloud device, press the Reset button and
hold for about 40 seconds. The device undergoes a system restore and powers on.

In summary, MC can do system restore on both browser and physically (reset button) and system restore is resetting MC OS to default values.

If 40-second reset does not work for you, factory restore may needed. (your content will lost)

Thank you for your help and your experience - greatly appreciated!!

One question - “it take some time for the MyCloud to initialize itself” - how long?? - I have done as you said and am now getting Solid white -> Flashing yellow but still no Blue light - though there is lots of disc activity that there wasn’t before!

Does it take 5 mins, 30 mins, 1 hour to initialize??

So I have tried various combinations of powering on and off, holding the reset button for 40 seconds and for up to 5 minutes - I have done all of this fully clothed, partially clothed and now completely naked - none of this works! - I still get the flashing yellow led and no blue led.

Can I now safely assume that I need to attempt this “unbricking” procedure that I an reading about?? - by the way, the drive is 1 month out of warranty…

Today I bought a Synology NAS - I will never ever buy another WD product again - this is the 3rd one to fail on me…

1 Like

Well, if it’s the NIC that has failed, which does sound likely, it’s a hardware failure, and no amount of unbricking will help (well, I suppose the driver could have been corrupted). The best you are likely to do is to recover the HDD and use it as an internal or external drive.

Just for completeness, I might look to see if the router upgraded its firmware whilst you were away. And that I’d reset it, too.

Thanks for your imput.

I have a 2Tb MyCloud connected to the same router so I’m assuming that the router is OK. It works perfectly with the Synology NAS too.

Also, the faulty unit doesn’t get to the blue stage when unplugged, so I’m assuming that it’s gonna end up in the skip with my other 3 WD MyClouds…

Yeah, if the router’s working okay for other devices, it certainly does look like the one device is duff. I guess for completeness, you could try unbricking, just in case it is simply the driver that’s been damaged somehow (although the critical stuff like that ought to be protected by the RAID arrangement on the OS partitions).

As for skipping, well, whilst the NAS board and firmware may be a bit questionable in quality, the actual HDDs are about as good as they come. Crack open the cases, and get the data off them, or just stick them in a PC with a spare SATA slot, format them, and either stick them in a USB enclosure, or sell them as HDDs.

I hate to see stuff skipped when there’s some life left it it… Possibly why I spend so much time here, trying to help… That and skip-diving…

Sorry for getting back to you that late…and you got a Synology NAS, which is obviously better than WD NAS.
Anyway. The HDD seems failed to me and it needs “unbrick”, which involves crack open the enclosure, plug into a PC to recover data if possible. Then restore it with MC image (try search somewhere in this forum).

Not necessarily. Apparently there is a possible way to unbrick a My Cloud without removing the drive from the WD encloure.

https://community.wd.com/t/unbricking-without-opening/95064

True. This the other way to unbrick MC

Before anyone does anything drastic to the drive, check the obvious with the network settings. Mine was blinking yellow, and it turned out the IP settings were in static but the router couldn’t access it. So it wasn’t even a cable issue. I don’t know why troubleshooting a yellow blinking light isn’t in the manual! It means no internet access - at least that’s one meaning, it could be something else too but there’s nothing in the manual! It could be cable OR settings on the drive OR the router connecting to the drive. The 40 second reset would probably work in a messed up IP setting case because it resets back to DHCP.

Well, the User Manual Troubleshooting section does discuss yellow front light and no network access…

The My Cloud Device’s front panel light is yellow and the unit’s Network
Adapter LEDs do not light.

One problem is that WD insist on changing the LED colours between generations and firmware builds. According to the Gen2 manual, the only front panel colours are blue and red. Gen1 colours were white, blue, yellow and red (pre-OS3), and white, blue and red (post-OS3).

Not entirely helpful…

Ok - I went back to the manual (http://www.wdc.com/wdproducts/library/UM/ENG/4779-705103.pdf) and see you are correct - there is a mention of yellow, it’s just on page 91, whereas page 7 describes the front panel LED behavior. Not exactly good writing, but at least it’s there, thanks for the tip. It’s also odd that they only describe physical problems making it yellow, when a bad IP address can also do the same thing.

Based on all the talk in the thread about sending it back or busting it open, I just hope someone debugging the issues here doesn’t just think it’s a hardware issue. It really blows when you go to the time and trouble of sending it back and being all pissed off, and they say, “works fine here!”

Cheers!

On the basis of the evidence presented here, I do think it probably is a hardware fault. The 4 second and 40 seconds resets will restore the default network settings and drop back to DHCP. This ought to be enough to allow the router to find it. My comment about extracting the HDDs was in preference to simply throwing the things in the skip.

I’ve love to suggest a settings or firmware fix, or a cable fix, but all the usual suspects seem to have been exhausted. If you can see any suggestion we’ve missed, or any settings or firmware-based solutions, please post them.

A few more debug suggestions from me:

  1. Contact WD Support, and send them a system log; it may point to the problem
  2. Have a look through the /usr/log files to see if there are any obvious error reports
  3. Use the ‘firmware downgrade’ cheat (search for it) so that you can fool the device into letting you reload its current firmware.
  4. Try swapping power supplies between the two MyClouds; one may have gone defective.

Thank you to everyone for their input - in particular cpt_paranoia.

The fault was indeed a hardware failure, I have put the 4Tb WD Red drive into a usb drive caddy and recovered all of the data from it to my new NAS, as suggested.

I also put a scathing review on Amazon and have been offered a replacement MyCloud by WD, but as I now have a drive caddy and a perfectly good drive, I’m just gonna stick with that and use it as a repository for dumping stuff while I move it around to NAS and my other backups.

Thanks you to all of you for your help, sorry to say you won’t be hearing from me again - my days of buying WD units are well and truly over…

Well, random device failures can occur with all products, either latent manufacturing faults, component faults, or failures caused by the electrical environment.

I’m not a WD apologist by any means, but the offer of a replacement seems pretty fair.

Hi Dunvegan, i am experiencing the same issue with my WD My cloud 4tb, could you please explain how you recovered your data? thanks in advance.

Try this:

SOLVED:

I know it is too late to answer to this post, but at least other people may use it.

we had the same issue, blinking orange power light. The problem was about the power adopter, for some reason it couldn’t provide enough power. After we’ve changed it, the system boot normally.
To test if it is about power, listen carefully to the system, you should hear a weak DC motor sound (it is actually hard disk trying to launch its main motor, but because the power is weak cannot) that comes and go. It means that the system cannot even turn on the hard-disk, then trying all of system resets would not have any effect.

The power adopter is a 12V power adopter.

Hope it help you.