MyCloud 4TB hangs up and disconnected in the middle of file transferring

  • my MyCloud 4Tb often hangs up in the middle of multiple file transferring (above 1gb) via direct drag and drop through win7 explorer
  • the copy bar progress is stuck and then windows cannot detect MyCloud… and after that, my internet goes down. until after i reboot the pc then the internet and connections back to normal (without restarting the router)

but this situation is not happening when i transfer the files through wd desktop app, although i’m having very slow transfer rate about 1mbps :confounded:

  • i’m using tp-link w8961nd
  • wired MyCloud to router and also wired the router to pc (not using any wifi)
  • got myself the gigabit ethernet card for pc

i’m curious about my current router (it’s not gigabit i know), but is it supposed to be that bad? or maybe another factor? anyone have same experience or a solution?

thanks guys :smiley:

What version of Windows are you running?  When I first setup my two MyClouds (2T and 3T) I did not have great success transferring large amounts of data using Windows File Explorer (Win8.1).  However I have had good experience using FreeFileSync (download and try it).  Transferring >1TB of data will take awhile but I usually let tasks like this go overnight.  Your LAN speed will affect things greatly.  Getting a Gig NIC for your PC is a good move but if it is connected to a 10/100 port on your router you won’t see that speed.  You might think about getting a new router with Gig ports or getting a Gig switch (eg 8-port Trendnet) and connecting your PC and MyCloud to it.  This will remove your router from most of your LAN traffic and you should notice faster transfers.

i’m using win7 home premium, service pack1

yeah i’m also suspecting the problem is with my router… but i’m curious if it is supposed to be this bad?

and what gigabit router you recommend me to use?

but i’m not sure if it will solve the problem or not after i change my router :confounded:

is it worth it? as buying the new one is a bit pricey and my current tp-link still works well for internet and wifi (less than one year usage) :neutral_face:


Here is what I did:

  1. Make sure that your My Cloud is not set to static IP in dashboard.

  2. Connect My Cloud Directly to your computer/laptop ethernet port. 

  3. Your windows 7 should automatically create network with My Cloud

  4. To check IP of My Cloud, you can use mc_windows_setup.exe (U don’t have to install anything, just let the installer to discover you MyCloud and it’s IP

  5. Map your shares by using //MyCloudIP/[Share or Public]

Thanks to this I know that on connection 1Gb/s card to 1Gb/s My Cloud, I have speed rate at level:

~34MB/s for bunch of small files

~72MB/s for one big file (aprox. 2GB)

Have you tried with another PC?

sorry for the late reply…

i was away for the last few days

tried both the static and dynamic IP, connected directly from mycloud to pc (gigabit ethernet - the upper and lower green lights are lit)

and yet the problem still persists:

  • i only got a slight increase in speed… and by i mean ‘increase’ is only max 1.2mbps from my previous 800kbps~1mbps … *doh :angry:
  • and the drive is still occasionally disconnect in the middle of file transfer

FYI: my MyCloud is only 1 week old


you did say that your router is NOT a gigabit router so from end to end (PC to your Cloud) is not a true gigabit connection (although it does make me wonder why the light is green). 

Nevertheless, just go get a a cheap gigabit router for about $50 with just the standard dual band Wifi N. As long as the ports are gigabit, then you are all set.

Do remember to not plug any 100Mbit devices in your router as this can take down your network speed. Just plug in your PC and your Cloud at the begining to test out the network speeds before adding other devices.

Good luck

so here’s my setup:

  • pc: gigabit
  • router: not gigabit
  • mycloud: gigabit

what i tried:

  1. connected pc → router → mycloud: it’s not gigabit (yellow+green light)
  2. connected pc → mycloud: it’s gigabit (green+green light)

well, my first problem is stated as number 1

and then @gerwaz4 told me to connect directly from pc to mycloud without router, so it should be as number 2

and i believe what @ralphael suggested me to do is also number2 (cmiiw)

but… the problem still exists either way

doesn’t that mean the problem is within mycloud?

NB: contacted the WD vendor and they promised me to help with the checking anytime

In your first post, you say your INTERNET goes down during a transfer?

There’s NOTHING the cloud can do to make your internet go down.   There’s something else wrong in your network or PC somewhere, but I’m at a loss of what to tell you to look at.

Have you tried another PC (just as a test) like with a friend’s PC or something?

Did you check “Link speed and duplex” property of your PC/Laptop Network card?

It is in the Device Manager.

Please set to to 1.0 Gbps and again connect MyCloud directly to your PC/Laptop to do a “clean” check

I hope this will solve your problem

1 Like

The trouble with troubleshooting someone’s else problems (a sep) is that you have no idea what they are doing… :stuck_out_tongue:

nevertheless…  using my psychic powers, lets start you off with a direct connect since you don’t want to buy a gigabit router and even if you do buy a gigabit router, the directions are the same, just that the cable goes to the router instead of a direct connect. 

WD in their infinite wisdom automatically detects if you plug in the ethernet cable to your pc; normally you would need a crossover cable.

If you are using a PC make sure discovery is on… 

  1. control panel

  2. network and sharing Centre

  3. Advance Sharing settings

  4. turn on network discovery


Mapping the Devices as a drive

This is how I’ve been using the NAS device by mapping the device as a local drive. SMB for Mac and Samba for PC’s. After mapping the shares as a drive, with the gigabit ethernet, the shares almost feels local.

On my Mac, once your WD Cloud is powered up 

  1. in finder, click Go

  2. select connect to server

  3. click browse

  4. you should see wdmycloud, double click on this 

  5. you will see Connected as: Guest,

   a. if you have already created users with access to certain shares then you must click on ‘Connect as’ and enter your       userid and password.

  1. select the shares that you want to connect and they will show up on your desktop. 

On the PC, 

1, click on computer

  1. click on map network drive

  2. click on browse under “what network folder would you like to map”

  3. click on WDMYCLOUD and if your shares has a userid and password, it will prompt you for it at this time

  4. you will see all your shares, select the one you want, Public is the default start up share

  5. click ok and click finish

  6. you can now see the NAS as a mapped drive in your Computer (treat it just like a local drive).

Once you have mapped your drive as a drive letter, just start copying files to it. 

Don’t use the Web utility as I have heard that it is bonkers :stuck_out_tongue:

Good luck

  1. i did check “link speed and duplex” in “device manager” and it’s already set to automatic
  2. then i check my network software: Bigfoot Killer Network Manager, and changed the internet provider speed upload and download to 1000megabits each (from previous upload:10megabits and download: 100megabits)

and suddenly the transfer speed is boosting up to 15mbps (non-gigabit) and up to 65mbps (gigabit) :smileyvery-happy:

phew thanks guys for the help, although i’m not sure if this speed (non-gigabit: 15mbps and gigabit 65mbps) is normal for a wired mycloud connection :neutral_face: