Slow or failing file transfers pc to mycloud


I have a MyCloud 3TB and recently have a problem with it. This is the situation:

I have the MyCloud wired connected to my router with gigabit connection.
My laptop on Windows 10 uses a 300mbps wireless N connection to my router.

Í have the MyCloud share as a mapped drive on my laptop.
In the past the speed of transferring files from my laptop to the MyCloud would reach stable speeds around 20MB/s and would never fail, which was enough for me.

But now the problem: Since about a couple of months i get only very slow speeds between 0 and 8 MB/s and they are highly fluctuating between this bandwith during the transfers and 9 out of 10 times the transfers drop to 0 and fail after a while (i quess time out). My not desirable workaround is often to use a usb stick but that really ■■■■■.

The weird thing is that the other way around, transferring from MyCloud to laptop, works still just fine like it used to with stable speeds around 20MB/s and no failing at all. This gives me the impression there is nothing wrong with the connection and it has something to do with settings, most likely in windows.

I have tried many things (reinstalling NIC drivers, restarting the Mycloud, tuning wifi settings etc etc) but nothing works.

I don’t know exactly when the problem started because i don’t transfer files very often but i have a suspicion it was after the last big Windows 10 1709 (creators fall) update.

Does anyone have any ideas i can try to solve this problem?


As a troubleshooting test connect the computer to the same router using an Ethernet wire and perform the same copy test to see if the issue persists.

Because you are using WiFi it is possible something changed recently like neighbors WiFi interfering with your WiFi. Or perhaps your WiFi router updated and the settings changed.

One troubleshooting step is to set the WiFi channel to a specific channel depending on which wireless band you are using. See your router’s documentation to see if there is an option to set a specific wireless channel. Also check any QoS settings which may limit/restrict copying files.

Hi Bennor,

Thanks for your reply.
I get what you are saying but if a wifi interference problem was the case i would also see this problem when transferring the other way around (from Mycloud to laptop) and that is not the case. My wifi speeds are also very good when down and uploading to the internet and the connection is a stable wireless N 300mbps. I’m no novice concerning wifi and have played around with wifi channels and bands with no effect.

At your advice i did try to transfer the same file trough a wired to wired gigabit connection and weirdly enough i get same results. While the other way around (from Mycloud to laptop) with this gigabit connection i get 100MB/s. So you did help me narrow it down because now i know it is a transfer from laptop to Mycloud problem no matter which connection i use. So this seems to be a windows 10 setting or something, but i have tried so many things already (like disabling antivirus/firewall, disable windows RDC feature, disabling netsh tcp auto-tuning feature etc etc). Or maybe it’s a problem with disk writing speeds when transferring a file frim laptop to mycloud.

This is getting real frustrating.