Mybookliveduo - looks to have formatted itself

I have been using the liveduo for last 2 years, it has 2 4tb drives and I use it as a 4tb nas with a backup drive incase of disasters.
Last night I was listening to audiobook on my phone through mycloud app, it got to end of the chapter and then could not connect again to play the next chapter. As it was late and I was in bed I left it untill this morning to reboot the Nas.
When I tried to access the dashboard using my pc it looks as though both drives have been formatted. I get the main screen to select a language and a button to Start setting up the nas…everything has gone,I had around 3.5tb of files but not anymore.
Could it have updated f/w or is it most likely a hardware issue ?
I have read previous posts on here about using linux ect to try to save my files, would it be worth trying this method…I have never used linux but willing to try anything at the minute.

Could it be the same issue a number of us experienced last night: Help! All data in mybook live gone and owner password unknown

oh wow, yep exact same issue.Thanks for the link I will follow that thread and see what happens, doubt we will get our data back though tbh.

Yes same happen to my Live Book Duo.All gone even the back up I am devastated! All my files and 20 years of travel photos just gone!

Yep lost everything, can’t believe the backup drive got wiped too. Never gonna buy any WD stuff again.

I’ve had issues getting into mylive duo over the last few days. I tried last night to get into it via app and also via PC. Mine also looks like all my files have disappeared.

When I click on the icon to access my drive, it’s only showing shared folders, with nothing in them. I’ve seen this b4 but a simple unplug the the nas drive reset it. This time nothing.

I even tried to put the HDs into q caddy to see if it was a network issue, but even that came up blank.

Deffo think this time my files has disappeared for ever. Well unhappy.

Hi I’ve lost all my photos, folders still showing but no data in any folders

The same thing happened to me. Does anyone from WD visit this forum to respond?

I think that may describe why. :frowning:

I was surprised to receive Sunday 06-27-2021 an email from your company with security advices for my WD My Book Live, but the advice was given too late. What devastated me the most, was the fact that last Wednesday 23rd, my system was restored to its factory default and all my data was erased.
Despite the fact that I have had already read all the information from the Product Security Portal, I am still doubtful about other concerns:
1. Is it possible that a Trojan could has been installed on my private network or on any other connected device?
2.Could I ever recover my data ?
3. Would it be possible to use once again my device My Book Live with full security?

Finally, I would like to manifest my disappointment and emphasize that I still don’t understand why Western Digital abandoned their clients who trusted and bet for their first devices with private online storage.
As part of the first users community, I have witnessed the progressive abandonment without recent security updates, the restriction to one of the basics functions: the remote app-access from smartphones, and what is even worse, the vulnerability in front of outer attacks.

I personally think that such an enterprise like WD company should treat their clients otherwise, offering solutions instead of given facts, and understand that our documents, pictures, videos are the most valuable goods we owned, and lost while trusting your devices. I think that WD Company should take responsibility on such a situation and offer quick and effective solutions so we could trust once again their products as we did before.

With a compromised and rooted device on your network (your MBL), it is always possible that computers on the network could be compromised as well, however in this particular case that does not seem to have happened to anybody. The attackers were evidently only targeting the MBL.

You could possibly retrieve your data by using some of the available recovery tools. Also, WD will be offering data recovery free of charge as well as a trade-in offer this month, so in the meantime just unplug your MBL and wait until WD begins their data recovery and trade-in programs.

Your MBL was rooted, and as a result will always be suspect. It would be possible to use your MBL in a reasonably secure manner by doing the following:

  • Disabling remote access on the MBL (although mine was still attacked with this switched off)
  • Disabling UPNP on your router. This is probably the most important thing you can do.
  • if possible, in your router settings block the MBL’s IP address from accessing the internet or use MAC filtering.
    -A member here posted some patch code that is said to close the security vulnerabilities in the MBL, although installing it requires some knowledge of using SSL commands. I have not tested this solution.

But keep in mind, your MBL may have malicious code that was injected into it, and if it does, it should never be used. There are some tips on the big thread about this issue for ascertaining if this has occurred to your drive. Not everybody’s MBL had code injection.

Is there any indication that this was solely a reformat or were the hackers able to access/copy the data?

Thank you for your comments here, @Skyscape.
Could you please share a link to the “big thread” that you referred to?
Thanks

That’s the link in the first reply, best pour yourself a brew and get comfy, it’s a huge post now.

1 Like