MyBookLive 2TB - can't perform wireless backup (Win7)

I installed the SmartWare while plugged into my network.  That’s the only way the SmartWare would find the drive.  When I was connected wirelessly, it wouldn’t find it.  I “mapped” it to the letter Z:.

When I go to My Computer, the drive can be found under my “Network Places” and shows to still be called Z:, however I can’t set up wireless backups to the drive.  The SmartWare won’t recognize the drive as soon as I unplug my computer and go wireless.  I also can’t use Windows Backup Utility because it says I don’t have access (this may be purely my fault, I am a recent upgrader to Win7, I have Win7 professional and try to back up to a network location, and give my Windows acct/pw, tried my MyBook admin login/pw, but both times the backup failed with access denied).

What advice do you guys have for me to be able to wirelessly backup my drive?  Is there some setting I should check first that might be preventing this?  I am using DHCP mode for the drive, FWIW.


What is the make and model of your router?

try the following.

Open up a command prompt (Start > Run > cmd)

type in : ipconfig /flushDNS then hit enter.

Restart Smartware and see if it discovers the My Book Live now.

One other thought is to switch from DCHP to a static IP address to see if that helps.


FlushDNS and restarting SmartWare didn’t get it to recognize the drive.

I use an Actiontec GT724-WG router.   I set the WD drive to static ip using the web interface, and copied the settings from my router’s status page, but now I can’t load the web interface for the MyBook, it says the page isn’t responding.  It’s been about 15 minutes now.  If I hit the reset button on the back, will that reset the network settings without deleting files?

EDIT: I reset the network settings and entered Static IP information, this time it took it and seems to be working correctly as far as that goes, but the SmartWare still doesn’t recognize the drive, and I still can’t use Windows Backup with the MyBook. 

Thanks for the follow up information. Will try to track this down as to why this is happening.

regarding Windows Backup, what version of Windows are you running?

So, when you’re on WIRELESS can you do this:

Start /  in the SEARCH Box, type:  \mybooklive\

Does that open a window with the folders?   

If not, is it asking for a UserID / Password?  

If so, give it SOMETHING.   You can’t leave the User ID  blank, but on mine, this works (just ANY user name is fine.)

User ID:  lkjsdfojsdglkj

Password:  (Blank)

Instead of asking for login, if it gives you an error like:

"Windows cannot access \mybooklive\

Check the spelling of the name…  blah blah…"

then there’s something wrong with your wireless network profile or settings in the WiFi Access Point.

It may be because your Wireless Profile in Win7 has different security settings.  

When you’re WIRED, go down to the little icon in the status bar next to the clock (at least that’s where it is on mine) and find the little PC monitor that represents the network.   Hover your mouse over it and note the name.  On mine, it says “NETWORK 4.”

Now go wireless and do the same thing.   Does it have a different name?   If so, then it has a different profile that you need to adjust.

When I’m connected wirelessly, I can access the MyBook by using the search bar with no problem.  It also shows up under My Network Places and I can access it. 

I’ve been using my default admin login credentials/pw, the same ones I log in to my laptop with, to try to access the MyBook during windows backup, but it always returns the access denied error.  As for checking what kind of network names my wireless and wired networks have, my wireless network is showing to be called the combo of letters and numbers I named it, and my wired connection doesn’t show at all on the taskbar.  When I look at my network connections in the control panel, it shows to be called “Local Area Connection.”

I don’t know if it makes any difference, but I recently upgraded from XP to Win7.  I was having this same problem using XP/SmartWare and thought it may have been OS compatibility issues.  Is it possible it’s something in my wireless router’s settings?

Yeah, you’re right…  I forgot that the WLAN name shown is the SSID of the network.

Approach it this way:


Under the Network Name (whatever it is) it will indicate which profile is loaded. 

On mine, it’s called “HOME NETWORK”

But actually, I’m thinking it’s moot.   I was under the impression that you weren’t able to get to the MBL AT ALL when wireless.   

I’m now wondering if SmartWare is bound to the IP address of the client and won’t let two IP addresses access the same data.

If your PC is using Dynamic Configuration, you’re going to get two different IPs:  One for WIRELESS and one for WIRED.  

You’d have to go set the IP address MANUALLY for both adapters (and make sure they’re NEVER active at the same time) to see if that’s the case.