MyBook Live Stuck At End of Firmware Update

It’s been sitting at “Firmware Update Succesful. Initialzing device.” for the past hour and it tells me to not close the web page or unplug the device. Is this normal? And, if so, when does it typically complete? I can still access the device, run media from it, etc., even though the light on the front is yellow/orange (and re-accessing the web page says status is “bad” if I go to it in a new browser window) but I don’t dare shut the window or reboot the device w/o knowing I’m not going to kill it, so a little help, please.

Edit: and my browser crashed 2 hours later (for a total of 3 hours stuck on the end of a firmware update)…now I’m sitting here w/ a yellow light on my drive, the web-based utility says my drive is “bad” (but I can stilll get to it in Windows Explorer) and, after prompting me to, once again, update the firmware, it says my firmware is, in fact, up-do-date. So, now, what do I do to make the web-based utility say my drive is “good” and restore the drive to normal, operating, parameters? Hard reset?

First of all. If you can access it - save your data!

 Agree with the previous post, if you can access your data, pull it off first.

Unplug the unit from the power, leave it off for about 1 min. Then plug the unit back in to power it up.

If the LED stays in yellow/orange, then please contact WD Support and get an RMA to replace your unit.  At this point, there is not much more troubleshooting you can do.

If it goes to green, then go into the device user interface and check in Settings, Update section if the firmware has changed to 01.02.03.  If so, you are good to go.

my firmware update did not complete properly either.  I rebooted the drive and the wireless router assigned it a new IP.  I had to remap and get smartware to see the drive at it’s new IP, but the firmware was installed completely and the drive is working fine.

I encountered the same problem.  I just shut my browser down after an hour.  The drive works just fine, however the light on the front stays yellow.  I tried rebooting, shutting down, pulling the plug, but no change in the light.  I’m just happy it still works.

Good news: I hadn’t had the time to send the drive back for an RMA, but I did take a (small) risk and run the most recent firmware update and, voila, it’s now back to behaving normally, so perhaps t his can help some other people stuck w/ the yellow light and “bad” reading in the dash.

Good luck!

Ok this happen to me !

First I tried to download the new firmware I was prompted to do.

It hangs up after about 2hours at the end . I re start and get  a prompt that an updated firmware needed to be installed

The install went all the way this time but hung up on the restart process. Let it sit over night then reset. I can access my files but  the thing is on the web page it has (status bad)/ yellow light on drive  . I can still access my files and I am backing them up. Every now and then my computer crashes and re starts windows. 5 hours to go.

HELP what is going on ?? 

Oops sorry,

I have the 2tb network Drive