Do NOT update firmware


#1

I got a notice from my 2TB drive yesterday that a firmware update was available.  I made the mistake of electing to install it.  It has been hung for nearly an hour and a half at “Firmware update was successful. Initializing device.”  I can hear the heads moving, and the LED changes back and forth from red to green, but the bottom line is that I’m hung there.


#2

Have you tried rebooting the drive by switching the power off and then on.


#3

Would you do that when you’re looking at a window that says, “Please do not unplug the device or close this window during the rebooting process.”?


#4

Well sooner or later you have to do something. The LED does not show that a upgrade is taking place and that message is on the computer screen. I know its a risk but in the past I have have taken the plunge and rebooted it. I now update via the quick view screen which makes the mybooklive update without messages on the computer screen. I have just updated that way and everything has gone OK. It took a few minutes to update and reboot.

While the firmware update is in progress the color is white and probably you will see a lot of activity on your router.

Obviously its up to you. Maybe somebody will come on from WD and give some better advice.

Can you access the mybooklive from your PC via the network?


#5

You have a point, but I’d prefer not to put 2TB of data at risk until (as you said) someone from WD speaks up either here or in response to support request.


#6

The WD Community was created for Users, such as yourself, to help one another, and to share your experiences and ideas with one another. As Moderators, we are here simply to facilitate and oversee the community. If you have a question relating the what’s going on in the community, we will be happy to respond. However, if you are looking for technical support from WD, you will need to contact them directly.

To Contact WD for Technical Support
http://support.wdc.com/contact/index.asp?lang=en


#7

I have done so, as I mentioned (in an admittedly incomplete and thus not very clear sentence) in my last comment.  Unfortunately, the response e-mail says they will try to respond in 24 hours, but it might be as many as 3 days.  I can call them if I wish to pay their support fee for the privilege of having them help fix the problem their own software caused, but that rankles quite badly.

In the meantime, I believe it’s appropriate for me to let the rest of the community know the risk they are taking if they choose to install the firmware update.


#8

Is the MyBook Live accessible through ANOTHER browser window?

If so, it could be that the webpage just didn’t update and something else is going on.


#9

Yes it is, TonyPH, and you may well be right.  I hope everyone can understand the level of concern that remains over one’s data when the original window looks so threatening.  If nothing else happens, I hope at some point someone from WD will take a look at the update process and address whatever is causing the “leave me the *&$# alone” window to not go away.  I have no choice but to try resetting the drive and hoping for the best.  Even if everything turns out to be fine, I’d argue there’s a real support issue with the amount of time I’ve lost waiting and the amount of concern that generates.  But I won’t be able to help them figure out what the next step is, because I’ve no choice but to go ahead and reset the drive.


#10

I would appreciate some input here, I’ve tried to update the firmware of my device here (2TB version) and it’s stuck for some time at the “Downloading” window.

Led is white on the device.

The device is accessible from my laptop.

It’s almost 30 mins now. What do you think I should do?


#11

I can’t answer your question, I’m afraid, but I hope more people will read the subject line of this thread before taking the plunge.  Theoretically, if the LED is white it’s still in process so you have to leave it alone.  And hope.


#12

FYI, I just got an e-mail from WD support: “The MyBookLive is designed to recover from a failed firmware update. You can unplug the drive’s power and let it spin down for a few seconds and then power it back up. The drive will revert to the old firmware again.”

That doesn’t tell me what happened, why, how to prevent it, or how to successfully install the update, but it does provide some relief that my data should be fine.


#13

The result of following that advice:

WD.jpg


#14

Can’t see pictures until a moderator approves them… POst them on an image sharing site and post a link instead.


#15

Sorry, Tony, it’s a picture of the status bar you see at the bottom of the web interface to the disk.  Where you normally see green circles moving out from the drive and the words STATUS: GOOD, I see STATUS: BAD.  I started the short diagnostic test (which is supposed to take 2 minutes) 15 minutes ago.  The progress bar got to about 85% and appears to be stuck there.


#16

I unplugged the power on the device then replugged it. The green line came back up shortly after, then I went back to the interface and thru the update panel I went on to update the firmware, this time it just went on just fine.

I start to believe one should go thru the usual update option rather than the pop-up one -the exclamation mark- for some reason that eludes me for some reason.

Or perhaps it just is not stable enough.


#17

To their credit, WD contacted me privately and I’ve just spent 45 minutes on the phone with them to get log information extracted and sent to their support folk.  I’m still stuck with doing a factory restore–and the complete reload from backup that comes with that–but hopefully they’ll learn what happened and fix it before it happens to someone else.  In the meantime, I have to suggest to everyone that you NOT install the update unless you absolutely have to have one of the fixes it includes.  Or at least be sure your backup is 100% up to date before you do.


#18

The Quick Factory Restore faithfully deleted my data, but did not fix the problem.  (The drive still indicates “Status: Bad.”)  I’ve had to begin a Full Factory Restore which their software popped up a window to tell me “may take hours to complete.”

UPDATE: Based on the progress meter after an hour, it looks like around a 10-hour process–which may or may not fix the problem.


#19

I should have checked this forum before updating My book live. I too am getting the status as bad. I am now running the full diagnostic test. Hopefully I’ll get some answers. In addition I have contacted the WD support for some help. I haven’t heard from them yet. I think one should strongly follow the policy of : if it ain’t broken, don’t fix it:). I guess I learn’t it the hard way.

PS: I wanted to know if I can rollback to the previous firware like I can with my wd live tv. Could someone plz help. Ones again, thanks.


#20

Ann, I’ve been online with their tech support for 4 full hours now.  Can I suggest something?  (And yes, I’m serious.)  Reboot your drive and then your computer, then reload the status page.  They’re shipping me a new drive, but now their engineers think it might have been a problem just with the web page that reports the status!  Clearing the cache completely and restarting both devices changed my status back to Good!?!?!?!?!?  I’m still left with about 24 hours to reload the 2TB erased from the drive during the factory restore, but it looks like the drive might not be totally trashed.