Firmware Update or Other Problem?

We have been having some problems with our MBL. We set it up a few months ago, and it has been working like a charm since. It is hooked into our router, and we have been accessing it wirelessly from our Macbook Pro’s. So far we have not had any issues, but suddenly a couple of days ago, it stopped showing up in either of our shared drives. I tried unplugging it for about a minute and replugging it in. Now the light is solid yellow, which would indicate a firmware update. Every so often, the LED goes off completely for about 5-10 seconds, then it comes back on yellow again. It is still not showing up in the shared drives, and I cant access it from the browser either. Is this normal for a firmware update? Or did I screw it up when I unplugged it, or is it possibly a different problem altogether? It has been about 2 hours since I restarted it, and it has been solid yellow that whole time, aside from the few times that the LED has shut off altogether for a few seconds. Any guidance would be greatly appreciated.

No.  Solid yellow means it’s booting.  Solid WHITE is a firmware update.

A yellow – off – yellow – off …

pattern indicates the drive is unable to boot.

Your drive has likely failed.

It blinks off once every 20-30 minutes, I think. If it has failed is there anything I can do to fix it?

Also, is there a way to pull the stored data off of it? I have literally only had it for a few months and it is on a stand with clear airflow and everything, so it should have have overheated or anything. And I was nowhere near filling it to capacity or anything like that.

Depends.   If the internal HD itself has failed, it would likely require you to send it to a data recovery service ($$$$) to get the data off the drive.   If it’s a software failure (not likely, since you weren’t doing anything to the software), or if the NAS chassis failed (but the drive is OK) you can follow one of nfodiz’s guides (found in this forum) to recover the data.

All that I might add to what Tony says is to try using the reset button which is recessed on the back of the unit. Insert the end of a straightened paperclip in the opening and hold it down for longer than the 4 seconds that the manual calls for. What I have seen called for something like 20 seconds.

Here is a Knowledge Base article which addresses network drives not being seen on the network-,335/session/L3RpbWUvMTM3ODg2MzM2MC9zaWQvQmY3MWEqemw%3D

At this point, Tony is on top of things and I will step back so as not to muddy the water.