MyBook Live 2 Mapping

Hello,

Having similar problems to lots of people i think and have followed steps posted by others with some success but not complete and now not sure if I have conflicted things so looking for a check list!

I recently upgraded to a new Laptop with Windows 10 Home on.

No MyBookLive 2 showing. I have now managed to get it to show but it shows as a media device. It will flick and appear as server at the bottom but not long enough to do anything with. At some point I did manage some success and managed to map Y and Z drives as shown in my pic to give me a shortcut to films and pics on device. However this success worked once and now seems to be “forgotten”.

I can access the device if I go to “My PC” in explorer and then click the MYBOOK Twonky image/icon that shows on my network but this then opens a directory structure which is not that which I collated my pics and films into but some sort of standard WD structure. It helps as it means my data is not lost but isn’t how I used to access info.

As I say I have run loads of things in admin mode on command prompt and amended settings as been scouring the web but now feel have gone in circle and not sure if something conflicts maybe. Happy to provide any further info on config as annoyed with WD/MS for this issue as should not need to be an IT guru!

When Microsoft disabled SMB 1.0 support for security reasons they also disabled parts of Windows’ Network Discovery that depends on SMB 1.0. This means that some NAS devices will no longer appear in the Window Network display in My PC. This in no way prevents access to your MyBookLive either as a mapped device or by using the device’s UNC.

so how do i resolve this so i can see it with the directory structure i set and not its own one as below

If you put
\MyBookLive2
in the File Explorer address line and hit enter you should see the shares you’ve defined on your MBL. You should be able to navigate to the directory you want. If you know the complete path to the directory or file you want, you can specify that complete path. Or you can map a Windows drive letter to it.

It doesn’t like that. It did work once and I managed to map the drive letters but it has dropped back out and I can now only see it as media element and not a file directory.

Is that true even if you correct for my typo and use “\” instead of “”? If so, you may have something more serious than Windows’ lack of SMB 1.0.

Have you gone through the regular Win10 steps of confirming your computer is “discoverable” and the you are using the “Private” network profile? Have you made sure NetBIOS over TCP/P is enabled? Getting these wrong will prevent access to NAS shares.

The changes MS made to Windows networking may be a pain to work around, but they were made to reduce some significant security holes.