Cannot Map Drive in Windows 10

After an update to My Book Live firmware and the latest update in Windows 10, my previously mapped drive doesn’t work any longer. When trying to map a fresh one, receive the Windows error, unable to find drive. Yet, under my “Network” places, the My Book Live is there but when I click on the icon, it just launches the browser to my local IP of MBL to the admin dashboard. Next, I ran the Windows trouble-shooter during the mapping process and displayed the following diagnostic error, "The device or resource (MyBookLive) is not set up to accept connections on
port “The File and printer sharing (SMB)”. So I go back into the MBL admin portal, but cannot find any thing related to this Windows setting. One other weird issue, under Network Locations, I see a different icon called “MyBookLive”, when I click on this, it opens to show me “This PC\MyBookLive\storage\Public” and I can see all my folders but no files and if I try to move or copy a file to any folder in this view it won’t let me.

Just a thought:
Was “the latest update in Windows 10” the installation of the Anniversary Update, by any chance? If so, some of your “sharing” options may have been reset. The stealth change I ran into was a change to the network profile in use. It has to be “Private” for network discovery to work properly, and without network discovery working properly, MSB connections to NAS devices doesn’t work properly.

There are many posting on the web describing how to set this up. A reasonably good one is

Thanks @pokeefe - yes my latest significant W10 update was the Anniversary update. I check my network profile and it was already set to private. Just wondering if something is off with my use of homegroups and workgroups? Both laptop and MBL were set to the same workgroup name prior to my W10 update and I had created and joined a homegroup so my wife and I could share files. Those settings on my laptop and hers didn’t change after the W10 updates to both our computers and we can see each other’s laptops in the private home network, but neither of us can see the MBL in the network, which would definitely be why neither of us can map a network drive to it. Just frustrating as without mapping it as a network drive, neither of us can manage any of the files on the MBL. I can access its storage via the website WD2GO and have even downloaded the WD app from MSFT Store but that app only let’s me see media files, not all documents, etc.

Hmm. I’ve never messed with workgroups. I’ve kept the default name WORKGROUP on all devices. And I’ve never got homegroups to work consistantly. (That’s why I got a NAS device - so I wouldn’t have to figure out why my homegroup wouldn’t connect.)

I assume you already have “Turn on network discovery” and “Turn on file and printer sharing” set if your laptops are doing file sharing. Yes? If not, turn them on. And you must have “Make this PC discoverable” since that (I think) is identical to using the “Private” network profile.

Can you ping the MBL IP addr from your laptops? Can you ping it by name?

In the Network section of File Explorer. right-click a blank part of the display, and select Details. Then right-click the header line and check “Discovery Method”. On my PC I see

(I currently have only one PC running, but you can see my two NAS devices.)

Is your display noticeably different?

Confirmed I have “Make this PC discoverable” enabled. Confirmed I have “Turn on network discovery” and “Turn on file and printer sharing” enabled. I can ping successfully by IP number and hostname. In the Network section of File Explorer, I see the correct Network location and the same Discovery Method as yours, “SSDP”. However, one significant difference with mine, is MBL only appears under the “Storage” section, I don’t have it listed also under the “Computer” section.

It looks like you have two workgroups. I didn’t know you could have multiples. Make sure the workroup name in MBL matches one of them.

One other thing to checking is the NetBIOS support. This should be a problem only if you are using static IP addrs, but it’s worth checking anyway. Forgive me if you already know about this, but the parameter is a pain to find if you don’t already know where it lives so I’ll give detailed instructions.

  1. Get to the Network and Sharing Center (through the Control Panel , the Network and Internet setting in Settings, or any other way you know of).

  2. Double click Change adapter settings

  3. Double click your network adapter

  4. Click Properties

  5. Double-click TCP/IPv4

  6. Click Advanced

  7. Click the WINS tab

Look at the NetBIOS setting. It needs to be on. If you get your IP addr via DHCP, Default is ok. If you use static IP addrs then you need to set Enable NetBIOS over TCP/IP.

And that exhaust my knowledge of the topic. I guess it’s possible that SMP or UPnP support has been turned off in MBL, but I don’t know any way to do that or to turn it back on if it is turned off.

Hopefully somebody else will chime in if this hasn’t helped.

Thanks @pokeefe, really appreciate all the help. I went through these steps and verified that my network adapter was obtaining its IP automatically from DHCP.

Yes, hoping someone else might read this thread and provide any additional comments or contact WD support.

Thanks again…:v:

One other (very unlikely) thing to check. Make sure your firewalls aren’t blocking the NetBIOS over TCP/IP ports - TCP ports 137, 138, and 139.

Hey, I got it to work. I read your latest post, then just started reviewing all the other suggestions you made and went back and looked at NetBIOS over TCP/IP setting in the WINS tab and even though it was set to “Default” and that would be ok, I just said screw it and changed it to “Enable NetBIOS over TCP/IP”. When I went back into File Explorer–Network, MBL was now listed under the “Computer” section and I was able to map a drive to it.

Thanks again for all your help, PROBLEM RESOLVED!

1 Like

Hmm. There must be something else (poorly documented) besides static IP that makes makes the default value for NetBIOS over TCP/IP “disabled”. Another unanticipated feature of the Anniversary Update, I guess.

Glad you got it working!

I have also come across this problem recently. After trying various solutions, I was able to map drives using the IP address, but the MBL refused to appear in network locations.

Reading through all the solutions, I picked up a tiny bit of info, that seemed unimportant at the time.

I thought, what the hell. I changed the name of the MyBookLive in the dashboard to MYBOOKLIVE
Voila, problem solved.

Apparently, some of the network services in Windows 10 are case sensitive !!!

Very weird. I think that is a bug. I believe Windows uses both NetBIOS and SSDP in its network discovery schemes. Microsoft’s own documentation says says that the names in NetBIOS are not case sensitive. SSDP doc says it uses DNS names and the RFC governing domain names says they are not case sensitive.

If I understand the doc, SMB ignores case even in directory and file names. (I’m not sure the doc was current or that my understanding was correct. It doesn’t matter anyway in this context.)

If you can reproduce that problem I think you should report it to Microsoft.

I was scratching my head after going through a lot of troubleshooting:
during shared folder trouble report i received the following message:
"The device or resource (mybooklive) is not set up to accept connections on port “The File and printer sharing (SMB)”.

and when I ran network adaptor troubleshooting it said “Windows can’t communicate with the device or resource (DNS server). The computer or service you are trying to reach might be temporarily unavailable.”

I followed your fix and issue resolved in seconds! thanks for the fiX!

I seriously can’t believe all the troubleshooting steps above and nothing worked until I renamed MYBOOK’s device name to the same name in ALL CAPS and it worked. Silliness… Thanks everyone for the help!!