MyBook Essential 2TB USB3 - controller rev 13R

Hi guys,

My MYBook Essential 2TB USB3.0 is no longer recognised by the PC and I’d like to get my data back. The unit was working oksy before this, and I can hear the drive spin and self-test okay (status light stays on when powered up), but when I connect to the PC, it just flashes 3 times a second, and locks up the system. I can’t see it in the Disk Manager, and when I unplug the USB, the system tells me my disk must be initialized first. 

I decided to try and recover the data by opening the case and connecting the bare drive directly by SATA instead of using the USB3 , but research via google I find that the controller has Hardware Encryption and I can’t read the data without a Controller board. My Board has Rev. 13R on it, do I have to get the exact same one in order to decrypt the data ?  I didn’t use any passwords, and didn’t use the Smartware software to backup. I used it as an External Storage device, and now regretting ever using this MyBook instead of a plain external drive.

Has anyone tried using different revisions of the USB controller board to recover data ?

I know WD don’t supply spare parts, so I have to source a new controller board from somewhere, but there’s still no guarantee that a replacement will enable me to recover my data. Any advice from people who have been through this pain before please ?

I am in Queensland, Australia.


I don’t think it will work, only the original board can decrypt the files. On this type of case only a professional data recovery company can help.

Time for an update on my problem -

I managed to replace my rev 13R board with an rev AA board from a friend’s MyBook Essential case, and it WORKS !

I recovered my files using the EASEUS Data Recovery Wizard, as the MFT or partition table was damaged, and that program salvaged the data.

So the boards ARE replaceable for these cases. I didn’t use any software encryption, only the inbuilt hardware encryption supplied by the USB3.0 controller.

Just thought I’d give my feedback so that others can benefit. 

1 Like

Thanks for the feedback. Data recovery professionals have told me that they try to obtain a replacement board from an identical product of the same capacity. Often this works straightaway. At other times they need to account for incompatibilities by transferring the firmware chip (an 8-pin serial flash memory). Some professionals know how to work around certain incompatibilities (eg capacity differences) by editing a special sector near the SmartWare area at the end of the drive.

1 Like

My WD Mybook Essentials 2T just freaked out on me.  Worked great the other day as an external hard drive and then it made that horrible clicking noise for a little while.  Now it’s quiet again, recognized in device manager and windows explorer but all data (900+ GB) disappeared.  Would replacing the board with a rev AA (as in previous posts) create a way to recover all my data?  

I am going through thsi same exact siutation. My 2TB drive failed on me a couple weeks ago after having it for only a year and 6 months. The drive is clicking and the light is bliking but doesn’t show in Windows other than the Disk Maagement where it is says there is an I/O error but won’t initialize. I took it to a recovery company and they quoted me 178 bucks for parts and 1800 for recovery…which I thought was ridiculous. The controller board has 13r on it too and I am going to get the AA revisoion board in hopes that it works.