My WDTV life is not accessing my NAS anylonger


Since a couple of days, when I try to connect my WDTV life to my NAS(Synology DS214se) I get a message saying “Impossible to connect to the selected source” while the connection to my PC works fine.

Strange enough, the NAS appears as DiskStation along with my PC when selecting the possible sources (using the red button > network sharing > Windows sharing.

I have switched off all the components of my home network(router, PC, NAS, WDTV) and restated all of them but without any success.
I also reset the WDTV, the NAS and the router. Same result.

The installed firmware release is 2.01.86.
MAny thanks to whoever can give me a hint on how to solve this access problem.

If you are still able to access files within your computer then the issue relates to the NAS itself. Did you update your NAS’s firmware recently? Did you change permission settings? What happens if you try to test a new public share within your NAS in order to confirm if the issue relates to a specific location?

I have had problems with source disconnected do you want to search etc. I have a Seagate 2TD hard drive attached to the media player. Ver 2.02.32. Recently it refused to recognise it. I tried all sorts of things with no success.I contacted customer support who advised me to delete all WD files and scan the hard drive for errors. Plugged it back in PRESTO up came compiling media files.Maybe the cure is that simple.