Wdtv hub unable to connect to selected source with buffalo nas

hey all. having a problem tryin to connect my buffalo nas to the media library. getting this error “Unable to connect to the selected source. Please make sure the selected source is active and available for sharing”

This only happened lately. The nas used to be showing up on the media library. i dont know has it changed since i updated the latest firmware. I can access the nas folders when i go to home screen and hit the red B button and select ‘media server’ so i dont think its a problem with sharing. If i select ‘network share’ i get the same error as above. Anyone have this problem?

If you have a username and password for your nas remove it on the hub and then reboot  and type it in again and save it this has worked for me when that has happened. Or if you have it set on your media library remove it from the library then do the above and add it again

Thanks a bunch! that worked. for those that have the same problem… you can find the clear login for network share in the

setup -> Network Settings -> Clear Login Info for Network Share