My WD TV HD Media Player (Gen 1) randomly stops playing any videos


my media player won’t play any videos, I know there in the right format etc. As I’ve had them playing before. Even the video I managed to watch less then an hour go won’t play back. All I get on chosing the video is a blank screen and nothing happens unless I go back to the home screen.

I’ve had this problem before where no video will play but usually a reset or unpluging it works, but this time nothing is working.

Any help please?

Have you tried playing the files from another source (USB memory, external hard drive)? That way you can verify if the problem is with the WDTV or where you have the videos saved. 

yeah i tried the same files on a usb stick and and external harddrive and tried playing them via my xbox as well. the result was that the xbox would play them either from the usb or hardrive. But the WDTV was having none of it. 

I’ve since had the idea of removing one of the files that was in the MKV format where as the others were using AVI. So far I’ve no problem playing the files now.

I just don’t understand how one file in the MKV format which is suppose to be supported by WDTV will one not play and two will cause all the other files not to play anyone know why this is?


will2k wrote:

…anyone know why this is?



Certain files will “hang” the renderer, which runs as a separate process on the box.

Once it’s hung, the only fix is to reboot the box.

MKVs are *VERY* reliable on the WDTV.   99% of my media are MKV files, and I’m busy as I write this post converting the 50-years of Bond Blu-ray collection to MKV right now because MKV is *MUCH* better supported than native BD m2ts files.

… but the MKVs have to be GOOD, not corrupted, not malformed, etc.