WDTV will not play video, outright


#1

Hi all.

Had my original WD TV for about 15 months.

It appears to have died on my suddenly in the last few weeks.

It powers up fine, shows menu’s for all the media on my 750gb Passport Essential drive and other external HD’s, but…it’s won’t play any of the media.  I click Play and nothing shows up, just a blank screen, I can go “back” into the menu’s and the unit does not appear to be frozen, it just won’t play anything.

Although cccasionally, if I leave it alone for a few days without powering it up, I might get it to play a single video, it’s very particular, it usually has to be a video the unit has played once before, and it often takes me hitting play a few times to prod it into action.  But, by the time the video ends, if I try to play something else, same result. No, it’s definitely not a remote control issue.

So my guess was the unit overheats and fries out after a short while of use?

It’s clearly out of warranty, think it’s irrepairable?

I tried upgrading to the latest firmware, same issue.

I even tried installing the WDLXTV modded firmware, same issue.

any ideas?


#2

Try unplugging it for a while (a few minutes.)

Where you adding media to your collection when this happened?   It could be you have an MKV file in there that uses Header Compression in a video track that the WDTV will seize up on if it’s attempted.