My WD passport is showing but not accessible

my passport is not accesible. it say to format the drive. but i cant do i have tried so many solution but problem still same

I recently tried to access my external hard drive when it displayed the error message:

'F:\ is not accessible.

The disk structure is corrupted and unreadable.’

I’m not an expert on anything like this, but I searched for solutions to other peoples similar problems, some of which I tried but none of which worked. I tried using command prompt. CHKDSK worked and scanned the hard drive (or did something like that) and said there were no problems with anything on it. If I try to use ‘CHKDSK f: /f’ or ‘/r’ or whatever I get the response:

'The type of the file system is NTFS.

Unable to determine volume version and state. CHKDSK aborted.’

Using ‘CHKNTFS f:’ gives me the response:

'The type of the file system is NTFS.

Cannot query state of drive F:’

I have tried going onto properties, tools, error checking, but it says ‘The disk check can’t be performed because Windows can’t access the disk.’

Also, on disk management it says the hard drive is completely empty and is using the RAW file system.

I have no idea what to do about this so any help would be greatly appreciated.

P.S. I would prefer to be able to recover the data on there, but am willing to sacrafice it all if it’s much easier than recovering it.
I dont wanna loose my data.

Have you tried another USB port directly connected to the PC rather than one that is located on a multiple port extender device? If the port is alive, I notice you get an audio sound after you plug it in, then you should be able to find in Explorer. Should work on 3.0 and 2.0 USB ports.

When one don’t have ownership access then that time one can face drive inaccessibility issue. I would suggest you to go to the properties and then check if you have all the admin rights. Also, in case you want recommendation for recovering data in inaccessible drive then download Stellar Free data recovery tool.

Very true Iizzy1…user should double check the properties to check what Admin and User has to this drive. However, I’m guessing that this user was already in the past, correctly accessing this device and it just started to go bad? User also noted that PC just did not recognize USB plugin to any other port…I believe. Also another PC may be checked…OR, the device is just bad!

There could be many reasons for any drive to become unresponsive or undetected. It can be a hardware issue or some software issue. The external drive may be detected by the system if you connect it to another PC, but it doesn’t respond.

You can try the below methods to fix the issue and extract the files from the inaccessible USB drive:

  1. Reboot your system - Shut down your system, remove the power cord wait for some time & then connect the power cord & boot your system.

  2. Try different PC or Laptop

  3. Re-install USB drivers

  4. Unplug all connected USB devices

  5. Fix USB root hub

  6. Try Data Recovery Software such as Stellar Data Recovery that will help you recover data from the drive.

Hope this will help.