Unable to access external wd passport drive


I can’t seem to access my 1tb hard drive. I’ve had this drive for a while and had no issues up until yesterday. I have about 900gb of content so not too happy to see it all go. I was moving some mp3 files around on the hard drive to tidy up the folders but as I was doing that, access to the hard drive was getting harder and harder.

I now can’t access the contents and file explorer only picks it up as a local disc anot a MY passport drive… the white light on the drive flashes constantly and occasionally stays lit before it starts flashing again.

help! how can I salvage this ?

Hello habib234,

You can follow below provided article to check the issues with the My Passport on Windows.


ok well I tried running digital media recovery on the drive overnight and after 10 hours, it only manage to retrieve 2gb out of a possible 900gb+. No sure whether this means the 898gb is irrecoverable or the software I use has very acute limitations.

I have now decided to format the drive…but windows is not allowing me to do even that !'ve selected the following parameters when attempting the format ;

File System (NTFS) Default
Allocation unite size Default allocation size
Format Options Quick Format

and still no joy ! any pointers ?

just some additional info, I now get a note saying

the volume does not contain a recognized file system.
Please make sure that all required file system drivers are loaded and that the volume is not corrupted…

any ideas ?