My Passport Wireless Pro won't turn on

Ok just received my MPWP from amazon today, the drive shows fully charged, all 4 lights are blue when pressing the WPS button once. Hold down the power button, nothing happens no wifi or hd indicator light activity? I’ve plugged into a PC I can see the drive as an external drive that’s it. I guess I have a DOA dead MPWP unless anyone can suggest anything. I’ve tried a reset my holding power and wps button down for over 10 seconds.


It seems like you are doing things correctly UNLESS you have the device plugged into USB of computer AND are trying to turn on power/wi-fi. Unit is designed to NOT work this way. If so, disconnect MPWP from USB of computer and press power.button until wireless LED is on and power LED blinks. Now try to connect phone or tablet to MPWP wireless signal to set it up.

Otherwise, I would say your unit is DOA. Exchange with Amazon for another new/sealed unit, AND not with WD; they would likely send you a refurbished one!

1 Like

Thanks, I’ve sent it back to Amazon, it was a warehouse deal so it was sent back to Amazon broken, I guess amazon either didn’t check it or it’s gone wrong in between them checking and getting to me.

After packing it away to send back and ordering a new one I had a thought. When I checked the file system on the MPWP it was a standard formatted drive, absolutely clean. I’m guessing there should be a WDWP file system ? Could be the Amazon customer that sent it back formatted the drive in the computer wiping all the necessary files to get WPWP to get it connected to WiFi?

Good, I hope you ordered a brand hew one this time. Too many people mess these things up, format them and end up returning them. I never buy pricey gear that was a return. Be sure you download the complete user manual.

I’ve downloaded manually ages ago, I can’t remember seeing anything about restoring the drive to factory after formatting the drive ?


It’s in there and either called reset or restore to defaults. Search pdf for the words. No matter you are returning it.

Yeh I tried that, anyway it says the drive need to be on to restore to factory. Drive doesn’t turn on. Hopefully new drive will work !

Good news new drive works :+1:t2:

Btw offloading the images from sd card seems to be pretty quick contrary what I’ve heard about slow transfer.