My Passport Wireless Pro - System Recovery or Hard Drive replacement


#1

If you still have a warranty, this does not apply to you! Submit a support ticket with WD instead of trying this!

You will also be trying all this at your own risk! No one except yourself will be responsible if you turn your MPWP (My Passport Wireless Pro) into a paper weight!


**

WARNING: I tried replacing the hard drive with a Samsung EVO 840 SSD on 2017-08-20 and the firmware restore script had issues and it just looped. DO NOT TRY THIS unless you connect to the UART and have an understanding on how arm works and/or hardware hacking.

**


Now that is out of the way… I’m planning on messing around with the official firmware and extending it. I was thinking about doing Gentoo instead but decided not to compile since there was that battery thing with the first gen that seems to be fixed with a firmware patch and I rather not deal with all that… Anyway, before playing around I wanted to recover on a different hard drive, that way I know if stuff was in internal memory or if it’s on the hard drive.

What I’ve learned so far that’s related to recovering or replacing the hard drive:

  1. The serial console to see what’s going on/troubleshoot is really easy to attach without soldering. The standard 3v3 - 115200 settings worked for me on the SOC connection.
  2. The OS is on the hard drive.
  3. The initial wifi password is tied to the last 8 characters of hard drive serial number. So if you’re replacing the hard drive with a different one, please write it down or take a picture with your phone (what I did).

I did this on a 320GB HD that I’m planning on using for awhile before I eventually switching back to the 2T drive so I know you can go smaller, doubt there’s restrictions on going larger…

I thought I would share this info in case anyone else wants to play around or they’re unlucky and their hard drive die (please refer to first line of my post).

Step 1 - Download the firmware from WD https://support.wdc.com/downloads.aspx?g=235&lang=en
Step 2 - Format a SD card with the FAT-32 Filesystem
Step 3 - Create an folder on the SD card with the name ‘update’ (without the ‘’)
Step 4 - Copy the firmware file into the update folder
Step 5 - If you’re switching hard drives, this is the time to do it. I will warn you once again, make a note of the last 8 characters of the hard drive’s serial number. This will be your WiFi password.

Step 6 - Insert the SD card into your MPWP
Step 7 - Turn on your MPWP and quickly hold the SD/copy button for about 5 seconds. This will trigger the bootloader to restore the firmward that’s on the sd card.
Step 8 - Have your favorite beverage while the hard drive led flashes, that means it’s doing it’s thing…
Step 9 - The device will reboot once it’s done and then you’re good to setup :slight_smile:

Edit - Forgot to mention, part of the setup process is formatting your storage area with exfat.


#2

Hello,

Thank you for sharing this.


#3

Hi

How do you physically change the drive. I’ve been trying to change my drive but can’t find screws to open it

Cheers
Carlos


#4

Hello,

Are all 2.5inch hard drives/ssd compatible @PuDLeZ?

Thanks!


#5

Hi, has anyone tried if this is compatible with SSD?


#6

You take off the bottom of the drive, the side the doesn’t have the LEDs. While the following URL doesn’t tell you how to do it, it does show some pictures that should give you an idea on how it’s done.
http://www.anandtech.com/show/10431/western-digital-my-passport-wireless-pro-wifi-hard-drive-review


#7

They should fit inside but not sure if WD has some type of logic in the update script to see only certain hard drives.


#8

I will try with a Samsung EVO (think an 840?) later today. I want to reformat a laptop I have so I can take out the drive and give it a try before I do it.


#9

Please do! Thanks! As I mainly use it during outdoor trips, it would help a lot going SSD.


#10

Hmmm, It keeps looping from “Found update folder…” to the “sh: bad number.” Obviously something within the update script is not working properly with a samsung EVO 840 ssd. Maybe I was just lucky with the HDD I tried when I made these instructions. Sorry but I don’t have the time to research this further at the moment (life afk has been crazy busy). Hopefully someone else tries it and documents their work. If so, I will update my original post giving them the credit. If not, I will get a spare SSD (probably a WD one, hopefully it makes it easier) and will go through the update line by line (it’s a tar file of binaries and shell script/text files) to get an understanding where it will be throwing the “bad number” error.

Note: I updated my original post with a warning not to try this.

UART snippet of the error I’m experiencing below

Welcome to WD Korra Recovery
Korra login: updatefw
fw.version
updateVersion 1.03.04
updateMinorVersion 03
RecoverMinorVersion
sh: bad number
Found update folder in /tmp/usbmounts/SDcard
updatefw
fw.version
updateVersion 1.03.04
updateMinorVersion 03
RecoverMinorVersion
sh: bad number
Found update folder in /tmp/usbmounts/SDcard
updatefw
fw.version
updateVersion 1.03.04
updateMinorVersion 03
RecoverMinorVersion
sh: bad number


#11

Hi PuDlez - I have a broken one too that i am trying to fix . Do you have a picture of the cable that you did use for debugging ? - Thanks


#12

I used a “OSEPP FTDI” board that was in an electronics kit from several years ago. I googled it and besides the official site showing up first, the second result was amazon. Really any board should work as long as you can select the voltage or it’s 3v3


#13

The Passport Wireless SSD version is coming out, and from the looks of the support page it is using the same firmware as the non-SSD (Wireless Pro). The release notes for this firmware say:

“What’s new!
Added support for My Passport Wireless SSD”

I wonder if this makes it possible to swap out the regular drive in the Wireless Pro for an SSD without the error reported by @PuDLeZ above. Thoughts?


#14

Thanks for the heads up! I’ve been waiting for the release before I started modifying the firmware image. I will start looking more into the firmware tonight but a quick glance at it I see that it still checks the hard drive model (file ‘updatefw’ around line 101). I should be able to try with different drives (HDD and SDD) tomorrow night. If all goes well, I will update tomorrow otherwise I will try to debug the issue over the next few days and then provide an update.


#15

Edit: removed my previous reply

This will be my last update until I actually make some real progress…

My custom firmware works with the original HDD but is having an error with a SSD. I’m not sure if it works with other HDDs yet. I recently bought a Samsung Evo 860 SSD (was very recently released) that I’m going to dedicate to getting this working. I will also get a different HDD to dedicate to this project to minimize writing to the SSD until I get it working…

FYI: the custom firmware is throwing the following error.
cat: can’t open ‘/sys/block/sd*/device/vendor’: No such file or directory
cat: can’t open ‘/sys/block/sd*/device/model’: No such file or directory

I’m not sure if the SSD doesn’t have these fields or what as the output from the firmware is very limited. I haven’t modified the image too much because my end goal is to barely modify the official image so it will be easy for others to make the same modifications since you shouldn’t always trust things shared on community forums… Plus, I’m not sure if the admins/mods/wd will like me linking to a modified image of the official firmware, even if I put the disclaimer that people will be using it at their own risk without support from anyone.

Hopefully I can create an image so getting a new drive in the device is as simple of powering on, holding the battery/copy button, and sitting back while it does it’s thing. I know I did manually create a replacement drive in Linux but prefer not to go that route since internal PC drives will change the instructions too much, a lot of people aren’t good with math (to calculate positions), secure boot issues, and Linux/command line scares many…

If anyone else has some knowledge and would like to help, please send me a message and I can create a discord channel or something where we can collaborate on getting this done.


#16

It looks have to change firmware script , because in updatefw script from firmware, while check vendor and model, unless vendor == "WD and model == “My Passport 25AF” or "My Passport 2601, it won’t update. Although My Passport 2601 means supporting for wireless SSD, still need change with WD hard drive.


#17

Updating: replacing my passport wireless pro 2TB with sandisk 960GB works.

Key steps:

  1. Update wirelss pro from 1.02.24 to latest 1.04.17 on the wireless itself admin web. Direct update from sd card won’t work.

  2. Repartion and format sandisk ssd to exfat, and leave 4GB disk with no partition.

  3. Download http://download.wdc.com/nas/MyPassportWirelessGen2_1.04.17.bin and copy to update folder on a Fat32 formatted sd card.

  4. Mount ssd and update by sd card mode again.

  5. After firmware update, wireless pro shows as new wireless pro ssd with 960GB disk.

Note:
MyPassportWirelessGen2_1.04.17.bin not reject updating new vendor’s ssd. Instead, change firmware script and md5, then re-tar the bin file doesn’t work.


#18

Nice! Glad you made progress here. I’m just wondering why you need to leave 4 GB unpartitioned space?
And is there progress with the Samsung EVO 860 SSD?


#19

I haven’t tried since the day after I made the post, work and life afk… I do know I can make a replacement hard drive by manually creating all the partitions in Linux, I’m just trying to find a simple way for others to do it. Preferable with a “firmware” file so the only things people would really need is a SD card and the device itself.

The 4GB of space is for the OS and stuff. When a drive is in the MPWP/MPWSSD, it automatically doesn’t show the last 4GB of the drive like it would with removing the drive from the device and hooking it up to a PC. For example, one of the first drives I manually created a replacement drive looked like this when I connected it to my PC outside of the device:
Disk /dev/sdf: 298.1 GiB, 320072932864 bytes, 625142447 sectors:

When I connected it to my PC with the drive inside the MPWP enclosure it looked like
Disk /dev/sdf: 294.1 GiB, 315744059392 bytes, 616687616 sectors

The 4GB get’s broken up into three devices on the device /dev/sdb (two 512M partitions), /dev/sdc (two 512M partitions), and /dev/sdd (two 1G partitions). My notes I have in my email say:

sdb1 was a backup firmware image/file (MyPassportWirelessGen2_1.01.07.bin)
sdb2 was empty. I think when you gather the log through the webui to send to WD it gets stored here?
sdc1 was bootloader/kernel stuff (think it was just a temp/backup before it gets flashed to the board)
sdc2 is swap
sdd1 the os root filesystem.
sdd2 the os root filesystem.

I believe WD does a similar thing like they did with MyCould where firmware upgrades do one of the partitions so if there’s an issue, it can fail back to the other. If the firmware update goes properly, it uses raid1 to get the partitions in sync.


#20

@George2018: Did you hard code the vendor and model inside the updatefw? In my tests, I commented/skipped the ‘if’ statement that did the check…