My Passport Wireless Pro No Longer Charges, is this covered under Warranty?

My 4 TB Wireless Pro has been in storage for 3 months (being a backup that it is). Today i start it up and all is fine when accessed via USB Cable to my PC.

The Problem is detected when I want to use it wirelessly aka using the battery and hey presto pressing the power button does nothing. I tried charging via the provided charger and usb cable and after 2 hours it only show 1 blinking blue light. I unplugged and tried it again but to no avail.
I noticed that even while connected to the charger (aka trying to charge), i cannot power-on the hdd to use it wirelessly.

My HDD is still covered by Warranty but does this aspect of the device get covered?
DOES ANYBODY HAVE A SIMILAR EXPERIENCE? Or perhaps has successfully claimed warranty for the same problem?

Appreciate the response. thanks

I would leave the device on its charger overnight and see if it gets fully charged. If the problem continues, contact the WD Support team directly.

I have left it connected to the charger for over 6 hours yet the level never rose and it just doesnt turn on when i unplug it.

I am in Indonesia, where can I go to get RMA processed.

Thank You

Here is an online form to submit the question/issue -

thank you, i have just submitted via the form you provided and already have contacted through a different contact form in this website as well.