My Passport Ultra wants a password I never set

It’s a 2tb usb portable drive which I had two system backups stored on it and wanted to replace them BUT I keep getting a message that the drive is locked.
It wants a password which I don’t know.
I tried to low level format the drive but it still says I needs this unknown password.
How do I get out of this?
I forgot to add that the drive now has two partitions.
One partition 1862.99GB Allocated. The Other partitions says it’s a 30mb CD-ROM. Online.
WD Unlocker
Healthy Primary partition.
I’ve worked on computer for 30 years or so and have never seen something like this.


If you don’t need the data, you type the passport wrong five time and the unit should ask you to reformat and allowing you to open it.

I’ll recommend you to contact WD support for direct assistance on this case.

WD contact info:

I just finished fixing it. I was able using WD’s Utilities to erase the first partition which wiped out the message telling me I needed a password to continue.
The second partition which thought it was a CD-rom was wiped out when I was now able to run a low-level formatter. Which completely eliminated that partition.
Then using MS disk management tools initialed the drive then I was able to complete a regular format of the drive and the drive is working as it should.
I would like to know how this can happen. I have both my PC’s backed up using MS backup using one drive for the notebook and the other drive for my desktop.
Then I copy each backup to each other so I have 2 drives just for my system backup’s.
My data backups are on 4 drives for each machine and 4 other drives for my music.
I have all my data and OS backed up data on a total of 14 drives.
Having only 1 backup insane.