My passport Ultra not recognized in Windows 10

When I plug in my passport ultra it does not show in the available drives. It shows under connected devices but I can not access the content on it HELP

Hi, can you please tell us what message it shows while you attempt to access it.

There is no message. Its not recognized. But when i look at connected devices i see ot there

I would suggest you to go to the Disk Management and change the name of a drive letter and then restart your system. Hope it will work for you!!

Funny thing. I changed the cord I was using and it worked just fine.Im
thinking that cord was not up to par thank you for your assistance

Go here: https://support.microsoft.com/en-us/contactus/?pid=17655&TID=&STID It’s MS FREE support chat line. They will take over your computer (with your permission of course) and guide you through any issues you might have. I go there frequently because my WIN 10 is an upgrade and there have been issues that they gladly have helped me with.
I’m very sure they can help you with this question/issue you have.
Good luck.
EL

My Passport Ultra 2T is not recognized in Windows 10 either. I ran the WD Drive Utilities and everything checks out. SMART status passed and Quick Drive Test passed. I just have no way to access the data on the drive. There is no drive listed in File Explorer.

No problems with thumb drives, my computer recognizes all of them.

When I changed to a shorter usb cord and plugged directly into computer and
not the hub it read just fine. Maybe you can try that.

Mine has the 12 inch cord plugged directly into my computer. I don’t even own a hub.

My 2tb MyBook is also not recognized by my pc with windows10. Today i’ve spent a couple of hours with an attendent from microsoft that said to do some changes in my pc, even asked me to change the cord, but nothing made difference. Afterall he told me that the problem is in my device, but, a week ago before another windows upgrade, i could use my hd, and today when i put it in my daugthers pc, running linux, it could see my hd. The main problem is with microsoft development department that cannot creat a software stable and able to see all devices. But the question is, if i need to upgrade my firmware, and the windows cannot see it, how i do to that in a linux environment?

When I plug my passport ultra it does not show it either in Linux mint or Windows 10. I tried to open it using another pc(hp notebook) or dell desktop and it doesn’t show up. I have checked it using disk management and it says Disk 2 Unknown 1862.99GB Not initialized. When I tried to initialize it with MBR Virtual disk manager says the device is not ready. Please help me I need every material I have in there. Sorry for my English.

Hi Mr Oliverpowell
My harddisk is not loading in pc
Could u suggest anything …
If we connect to pc, the pc will hand and it is not showing anything . It is showing only the disk
Wat is the problem in it.