Newly Purchased WD Passport Ultra not recognized in Windows10


#1

I have just purchased a new passport ultra, never used & was excited to plug it in to my desktop. Then quickly realized that it doesn’t show up at all. I have downloaded software from WD site, but still no success. Very disappointed that I have wasted my money. Will not be suggesting anyone purchase WD products as I’ve read hundreds of similar reviews stating the same issues as I am having. Manufacturer is doing nothing about this issue to rectify. Shameful & infuryating. Has anyone any suggestions? I would really appreciate anything.


#2

Hello,

Are you getting any lights on the drive?

Have you tried a different computer?

Is the drive showing under disk management?

If possible, try using a different USB cable.


#3

Hi, have tried it on three computers, one of these is a brand new Microsoft surface. The cord I am using is the one that came with the passport ultra & was just unwrapped from the box it came in. I’ve tried different sub ports as well.
I have followed every suggestion on the forum pages & still no success. Light comes on the drive & I can hear it spinning. I have updated all drivers & downloaded software from the WD site.
Today I purchased a seagate drive & it works perfectly.
Very frustrated at this situation, & seems to be a common issue with many others. After spending so much money & time, I’ve given up!
Cheers
Rob