My Passport Ultra - Not detected!


My Passport Ultra doesn’t work anymore. And this is the second time I am having problems with this device. First time, it started to work really slow and became quite unresponsive. Anyhow, I got it exchanged at the store.

Now this new drive was working fine for around 2 months, at least for a couple of times it was used. Then just the other day, I put on around 4GB of data and removed it from my computer (it was not removed safely, of course).  After that, I put it in another computer and it didn’t work. There was no plug in sound, no detection in My Computer (Windows 7 x64) and no detection in disk manager. I tried a couple of different recovery/test software: DMDE, testdisk-7.0, and WD Data LifeGuard Diagnostics. It was not detected anywhere.

Symptoms when plugged in are:

  • Light comes on,

  • after a sec it starts to vibrate.

And that’s it.

I tried using another USB 2.0 micro cable with it and the symptoms are the same. The original USB 3.0 cable has two connectors, I suppose one is for extra power and one for data, so test with USB2 cable was “useless”. It looks like I have to buy a new cable to test if that’s the problem, but as it’s still under warranty I will probably just take it back again.

To summarize what I tried:

  • I tested it on 2 stationary win7 computers on different usb3.0 ports and usb2.0 ports. I might try it on win8 laptop, but I doubt it will help.

  • Tried testing it with /recovery/test software

  • Tried using usb2.0 micro cable.

If anyone has any more ideas what to try, please do tell.

Hi univer, welcome to the WD Community.

I’m sorry to hear that you are unable to access your drive. This seems to be a defective unit.

WD have some data recovery partners and a few of them can provide you with a free assessment, I recommned to  contact one of them.