My Passport Ultra 1TB Access denied, Security Options blank

While downloading a music torrent, just as it was finishing the download My Passport Ultra 1TB (metal) external hard drive had some kind of event with my PC running Windows 10 Pro and I get an Access Denied message. I’ve had this drive for almost a year and have been using it without any problems. When I open the Security tab there are no security settings visible, only a message stating I do not have privileges to Edit or Read the disk as well as an Advanced button. When I click on Advanced I get the same message, same thing when I click on Change or Continue. Unable to run CHKDSK for the same reason, but I was able to run WD Data Lifeguard diagnostics and everything passed. The Take Ownership tool had no effect. I am the sole user of my computers with full Administrator privileges. I even tried using Windows 10 hidden administrator feature. Nada. Zip. Zilch.

The drive works fine on an older computer running Windows XP and I was able to verify the disk’s contents. I checked permissions and everything looked normal. I even gave Everyone total access on the XP computer but it made no difference on the Windows 10 machine. Drivers have been uninstalled and reinstalled. Updates checked. No change. Disk Administrator is unable to change the drive letter.

While plugged into my Windows 10 machine there is WMI-based activity on the external drive. The light blinks quickly and the activity keeps running up the memory and using the resources, and the drive gets warm. Using task Manager to end the WMI task had no effect, it simply restarts. But on the Windows XP there is no such problem and the drive operates normally.

I have a second older WD Passport external hard drive (125 GB) connected to my Windows 10 machine and it continues operating without any anomalies.

For almost two weeks I’ve searched the web and these forums and tried numerous procedures that have not worked. Any help would be much appreciated. Thank you.

Hello, I have no idea why this is happening, maybe another user can provide some information. Also, you might want to contact support and see if they have some information.