My Passport Smartware - Settings missing

I JUST want to REMOVE the password protection… and the drive refuses to allow it.  Back in the day i removed everything from the drive as I didn’t know it was necessary… I dont know if thats when the problems began… but at this point i have to say the software on this device blows.  I wouldn’t say that if i haven’t spent HOURS trying to get it to work.

I can unlock it still as i knwo the password, but i cannot use it on anything other than windows becuase only Windows can unlock it.  So I install smartware to try to remove the password.  However when doing that it loads up and it looks great everywhere in smartware… EXCEPT THE SETINGS are MISSING.  The settings tab only lists my computer and not the my passport.  The passport shows up under backup and retrieve, but not settings.

I tried to intall the software back to factory spect, but that doesnt work either because then I get an “application not started from drive” message.

The SES driver is supposedly important.  I install it, but it doesn’t change anything.  I have no settings in smartware, and the drive wont let me run “WD SmarWare.exe” to try to fix the issues.

I have searched this forum and see others have asked these similar questions and no one has ever gotten a response that fixed it.  So at tihs point?  Is this drive utterly worthless?  Do I have any recourse?


Please see page 39 and 40 of the user manual for instructions on how to disable the WD Security.