No settings in SmartWare for my Passport 1TB


I installed the WD SES driver on my Windows 7 machine and SmartWare (with latest update 1.6.4).

Everything seems to work fine, even securing the drive.

Unfortunately while the drive shows up in the various SmartWare tabs, including Backup, it is not present in the settings tab, where I can only see settings for my PC.

To be honest this is a Passport for MAC unit, re-formatted to NTFS and attached to my Win 7 PC.

I tried various software re-installation on multiple computer with same results.

What can I do to access the settings for my drive?

Thank you,


Have you tried updating the firmware as well?

Have not seen this issue before to be sincere

Go to settings ,  Is there any blue button on the lower left corner on the smartware window.

Yes I’ve tried to update the firmware but the applications says that the drive has already the latest available (1.10 if I remember well).

There’s no blue button on the lower left corner of the settings tab in Smartware.

I’ve installed WD Drive Utilities and with that I can set timer, start diagnostics, etc. but I’d like to have all integrated in SmartWare.

Try updating your adobe flash player, java, and microsoft .net framework.