My Passport Portable 4TB Just Stopped Working, But It's Not Dead


#1

Hey folks,

Out of nowhere today, I discovered that I was no longer able to access the contents on my WD 4TB USB 3.0 My Passport Portable External HD (MFR # WDBYFT0040BBL-WESN) that I purchased 3 months ago. I also noticed that when my drive is powered up, it now produces a low, soft buzzing sound, in one second intervals, alternating with the sound of (I believe) my disks trying to be engaged. They’re new sounds I’ve not heard before. The E: drive on my laptop where my HD used to show up no longer appears, however the light is on the drive itself and it’s attempting to connect with my laptop. The HD IS however recognized in Device Manager and the device status says “This Device is Working Properly.” The cables are fine (I’ve tried alternate ones) and the connection is secure. The drive simply seems stuck. And out of nowhere. Nothing has been dropped or bumped. I’m very cautious with how I handle this drive.

Like most folks, I’ve got a ton of info on my drive that I can’t afford to lose. Any idea what the problem is? Can it be fixed? I don’t want to jump to the conclusion that my only option is to pay a fortune to get the data recovered until I’ve exhausted all of my other options. Where should I go from here?

John


#2

Hi MaineHealth,

I would recommend you to plug the drive in any other computer and try, if it is being recognized in any other computer then first take a backup or transfer your files in any other drive otherwise you might loose all you data. You can check the link for more assistance:

https://support.wdc.com/knowledgebase/answer.aspx?ID=14104


#3

I am having the exact same problem, did you find a solution. I was happily backing up from my windows laptop to my WD 4TB elements passport when it suddenly couldn’t find the source. Since then, I have shut the computer down, changed cables etc. I also have a 1TB WD passport and this works fine with the same cables and PCs. I have also tried with another PC but same issues.

The light is on and it is “whirring”, ive checked disk management and it states device working properly, but I cannot access anything and when I try to “safely remove disk”, nothing happens. Please help, I spent £100 on this disk and it has precious data on it which I do not want to lose - only used it twice!