WD My passport is not recognised on laptop


I am new to this forum. I have a WD My Passport USB drive which has worked perfectly until today. When I plus it into the laptop it makes noises and the light appears, but it is not recognised anymore, so I can’t access any information on the hard drive. I have tried to see if the drivers are up to date, and according to what I can see, they are. I thought this was the problem, but it must be something else. Is anyone able to assist, as I have not idea what to do next.
Thank you

Hi, welcome to the community.

Have you tried different USB cables? Have you tried another computer? Did the drive fall?

Thankyou for the response. I have tried different cable and also a different computer but it still doesn’t get recognised. The hard drive light still comes on and it makes a noise as if it still works. I do t know how to tell if it is the hard drive or the computer. I worked out that the drivers are up to date, which is what I first thought the problem might have been.

what kind of noises does the drive make? clicking, spinning, buzzing?

I have this same issue, I have no files on it, so no big loss other than the cost of this drive… first install, installed the software from the hard drive, then when I went to format it, said it was in use, closed everything I could think of, went to windows explorer now shows as drive E: instead of WD My Passport as before. Can’t access it, deleting drivers does nothing, the drive just sits here, light flashing…

I have a same problem. I was using my drive and then it stopped responding. I unplugged it and after connecting it is detecting in device manger but cant see in My Computer. Also while windows detect it (slow than usual) it gives 3 clicking sounds.

Please advise what is means. is it the physical damage or we can do something about it.