Flashing light - not recognising device

Hi there,

When I connect my hard drive the ligt flashes and I can’t access anything - can someone please give me advice on how to fix this. 


yes i now to have recently had the exact same drama. im trying the diagnostics tool know but has been idle for hoours now. all other onlinr programmes ive tryed also do not work… WD PLEASE HELP US

Just received the same problems with my WD external.  Tried different ports, USB 2.0 cords, different PCs.  Not working.

Any assistance is greatly appreciated. 

Me too!

I’ve plugged it in to muptiple computers and multiple USB ports.

The light is flashing, and it’s making the normal whirring sounds but it’s just not showing up on my computer.

Odd thing is, when you go to “safely remove hardwire” the computer recognises it there.

Any help would be greatly appreciated :smiley:

Same issue aswell, as of yesterday.
I get I/O errors, won’t recognize it in ‘My computer’, has strange ‘rebooting’ noises coming from it, but IS  recognized in ‘devices’ and to safely remove.

I am having the same issue…computer recognizes my passport but wont connect

Hello everyone,

The flashing LED may be due to the SES driver could not complete install or the drive does not get enough power so it can not recognize by the computer:

  1. Try unplug the WD my passport drive from your computer.
  2. Restart your computer. When the computer is restarted and the windows desktop is ready go to step 3.
  3. Re-plug in your WD my passport drive to your computer.

Be sure to use a short USB cable like 1 foot long or the one came with the drive, Using any USB cable longer than that may not provide enough power to the drive and the drive will not become ready or just flashing LED.

It might be more helpful if you guys could provide more detail about your WD my passport drive such as model number, the size or that drive, and your computer Operating System such as Win7 32bit, Win7 64bit or XP32 etc.

Hi, I am having exactly the same problem.

Passport Model No: WDBACY50000ABL

Windows XP run on a desktop PC.

I can access the files through a portable media player played through the TV.

Have tried many “solutions” however nothing seems to work.

Hi guys, have you all tried using different USB cables or checking if the Passport is recognized on the disk management window? Avoid using extension USB cables or USB hubs, since this can cause power inconsistencies. Check the links below for some suggestion you can all try. 

How to test a drive for problems using Data Lifeguard Diagnostics for Windows

WD external drive is not assigned a drive letter by Windows or Mac OSX and data on the drive is inaccessible

How to access Disk Management in Windows XP, Vista, 7 or 8 to manage hard drives 

1 Like

I’m having exactly the same problem and after running diagnostics, I received the following test results :

 (Simply my WD Passport doesn’t appear in My Computer. It appears in Device Proprieties, in the control panel under Devices, but not in My Computer so i can’t access to see files inside it.)

Test Option: QUICK TEST
Model Number: WD My Passport 0740
Unit Serial Number: [Deleted]
Firmware Number: 1003
Capacity: 0.00 GB
SMART Status: Not Available
Test Result: PASS
Test Time: 12:49:54, March 24, 2014

What can I do else ?