1TB My Passport Problem

Good morning WD Community,

I will try to be as detailed as possible. I cannot access my external HD. I had it for about two years. It has a password. Under normal circumstances I would plug the USB into the laptop (Windows 8), click on WD Security under Devices and Drives, type in my pasword and voila. The HD would show up under the I drive. Four days ago I needed to transfer some files unto the HD, after not plugging it in for about a week.

Problem: When I plugged it in the light was flashing white frequently and the HD was making a beeping noise about every two seconds. The WD Security did not show up. After about a minute the beeping would stop but the frequent white flashing would continue. After about 10 minutes the frequency of the flashing goes from .5 seconds to about 2 seconds. The HD can be seen under Devices and Printers but as CD Drive (E), which I didn’t realize at first. It is also seen in Device Manager. After reading a forum (not this one), I tried several options, hopefully non-harmful.


1. Unplugging the HD and shutting down the laptop. Restarting the laptop and plugging the HD back in: Same syptoms.

  1. Leaving the HD plugged in until the laptop recognizes it. This was before I realized the laptop was recogizing it as CD Drive (E).

  2. I noticed there was a WD firmware update for my device on about 26 September. I realized I didn’t use the HD since the update and downloaded the the update unto my laptop. The update recognizes my HD but cannot update it, probably because it’s CD Drive (E), which I STILL didn’t realize.

After reading the WD forum,

I unplugged the HD and realized the CD Drive (E) thing when my devices went from 4 to 3, then back to 4 when I plugged it back.

  1. I looked under Disk Management. HD shows up as “CD-ROM E”, with 0MB capacity and 0MB unallocated space. Petition Style  “MBR”

  2. I downloaded and ran the DLG. It recogized the HD as WD My Passport with 0MB for Capacity. I ran a Quick Test. Test Results as “PASS” but the Smart Status was “Not Available”


Do I change the CD Drive (E) to I? If so, how?

Do I then run the firmware update?

Something else?


Sorry for the long and detailed post. Also, thanks in advance.

First I would try a different USB cable no longer that the original. Make sure you are not connecting through a hub. also try on a different PC if possible.


Thanks Joe for your quick response. I will try a new cable (from Best Buy I guess) and post the result later.

Did the new cable work?

It didn’t seem like that is the problem

Just an update. The new cable didn’t work. And I tried plugging it into various computers. The computers/laptops recognizes “something” is plugged in but the HD is still beeping, flashing white and inaccessible. Still showing as a CD drive.
Took it to a repair shop and same deal. They said its a brick. Keep in mind this happened for no reason. I also recognize that this is a MAJOR issue with Western Digital as the majority of these post are about dead HDs. The soldiers I serve with are have a petition going for AAFES/PX/BX to stop selling these and send the remaining stock back to the company as this problem has been happening on multiple bases.