My passport not detected

Raising this ticket with a little bit of hope to recover my data.
I have WD My Passport 5TB. its always plugged into my mac using adapter. since today i am unable to mount the hdd (it showed the error at first that i didn’t unplug it in proper way, but after that i tried to plug it once more and since then no error). i tried to run WD Drive utilities and security applications from WD site and all seems to be working fine and no errors detected. However when i try to mount it, i am unable to do so. Any help for recovery of the files will be grateful. I just bought the HDD couple of months back.

Hi @Saam
Please refer to the link of alternate 3rd Party Data Recovery Options
Title: Alternate 3rd Party Data Recovery Options link:
Link: Third-Party Data Recovery Software for Windows and macOS

Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for the best assistance and troubleshooting:

Try booting your Mac in Safe Mode (hold “Shift” during startup). This can sometimes help resolve issues caused by software conflicts. In Safe Mode, see if the WD My Passport shows up in Disk Utility.