My Netflix stopped working with latest firmware update


#1

Just updated the firmware and now Netflix will not connect. I already reset the services on the hub and deactivated the device on the Netflix website but no luck. The Netflix app starts up and tries to connect and then eventually says “We’re unable to connect you to Netflix. Please try again later.”  I really don’t want to reset the whole device. Please advise.

Thanks


#2

It’s a Netflix issue. I’m seeing the same thing on my TiVo.


#3

I will sit tight then, thanks much!:smiley:


#4

Hmmm. The Hub is working at the moment, thought… Odd…


#5

Mine is still not working.  It goes thru the “Connecting to Netflix…”,  “and Retrieveing files…” scrolls but then I get the “try again” button. It doesn’t act like the service has been reset.


#6

Netflix stopped working with my latest firmware update (4/12/11). The netflix service asks me if I’m a member and when I reply yes it ask me to sign in useing my email address, but it gives me no way to access an alphanumeric keys. I checked my Xbox and it’s playing Netflix fine.


#7

I don’t think the system setting option to reset all services is working. My accuweather service is retaining my local info even though I have reset the services 4 times now.


#8

Twanster, I think you’re fine. Just put the cursor in the box you want to type in and hit the enter button, the keyboard will appear then.


#9

This is exactly what has happened with my unit. The firmware update is junk…


#10

Thanks for the advice ivork, but no keyboard comes up. Right now I’m assuming a lot of people are going to start having problems with this firmware update and WD will start to deal with the issue quickly. A little optimistic maybe.


#11

It’s good to find an optimist. I hope you are right.:smiley:


#12

There’s a dedicated Firmware subforum with a WD moderated sticky for the new firmware, you know. Well apparently some of you don’t.:smileyvery-happy:


#13

You press OK on the blank to bring up the keyboard.


#14

Yes, I should have said “OK” instead of enter. I was hoping he had figured that out. :smileyvery-happy: