My El Capitan WD My Cloud experience so far

Dear all,

after using steadily WD My Cloud both on the local network and remotely, this is a summary of what I found so far accesing
my WD device  my Mac Book Pro (El Capitan):


It works.  However, please notice that you can only download folders as compressed zip files, usable but awkward.

  • Chrome - All OK.  Can upload both files and folderrs (drag 'n drop). No problems in downloading.
  • Firefox - Can upload files but NOT folders.
  • Safari - Can upload files but NOT folders.
    Not perfect but usable, although improvements would not go amiss.
  1. Local network
  • I have (so far) found no way of mounting automatically my share on My Cloud, but can only mount the public share.  Does any body have any ideas about it?
  • I can, however, mount the shae through afp:// or cifs://  >  I have not tried smb://.  When done so, the drive seems usabel, although I would need a lot more testing.
  1. Remote access

It should be noticed that my ISP does not provide me with a static IP address.  I therefore use a DNS for my router.  Accessing remotely the My Cloud drive under Yosemite worked perfectly either through the Mac Desktop App or as a folder (accessing the drive therough the https:// proticol).
Under El Capitan, a number of problems appeared:

  • WD Desktop utility had problem uploading abive 512 KB (that has been discussed in this forum elsewhere).
  • It is possible to mount remotely the drive and/or shares as drives on Finder however it is NOT possible to upload anything.
  • However, it is perfectly possible to copy files and folders through line commands in the terminal to/ftom the mounted MyCloud drive. (see also details in my message elsewhere in the forum)
  • I can accces and mount the My Cloud drive in Finder using AFP and CIFS using my (home)  VPN server.  Of course, there is some hit in performance wrt accessing the drive in Finder directly

IMMO, his clearly points out that El Capitan has got problems, not particularly WD.  It appears that Finder, for some reasons, has screwed up at least https:// remote access possibly more (a quick googling showed that El Capitan has got a number of networking issues).

I would be more than delighted if any body had any suggestion about my experience/difficulties.

With thanks and very best regards

PS - I find this Community Forum very helpful and enlightening: I agree with the comments of several members that WD should be actively involved in it as it is a very good vehicle for users and WD people to exchange information.  Thanks to you all.

hi i re installed the WD softwear again it dropped a shortcut on my desktop called WDMyCloud-Public alias

im able to enter the folders that way.

Announcement from Bill_S:

Dear adampcarvell and cpt_paranoia,

thank you for your replies.

adamptcarvell: what WD software have you reinstalled, please?

Thanks and best regards

How I worked around El Capitan problem with WD My Cloud