My cloud will not connect to my EX2 Ultra - appears offline

Hello - I have two EX2 Ultras in two different locations. My iPhone and iPad MyCloud iOS app sees both devices. When I login to - only one is online and the other appears offline (ironically the one in my same location on my desk).

They are both up and running. I can access them both via the iOS apps, as well as locally via web browsers.

I have tried rebooting the device and the router, I have turned off and re-enable cloud access - all to no avail.

This was all working fine / both accessible via MyCloud the last time I went to MyCloud a few weeks ago.


I just received my new Ex2 Ultra today. But cannot connect my Ex2 Ultra. It always shows offline. I clicked the “Accept your device’s security certificate” link, but the site can not be reached.

Very disappointing.

Can you connect to the EX2 through the phone / tablet app? That will help determine if the EX2 is connecting outside / past the router.

Have you tried a different mac / pc / browser to see if it’s browser issue?

I have the same issue, I can connect on my iphone via iOS but not my PC nor my ipad confusing?

Any help appreciated

I also have the same issue.

Received and set up a new MyCloud Ex2 Ultra yesterday. It is accessible locally from W10 File Explorer and through the Android app, but ‘Can’t connect to MyCloudEX2Ultra’ in

Have tried from Mac/Windows machines using different browsers.

Thanks for any help with this.

Have found the issue , in my case. My router was setting up a port mapping with UPnP - automatically assigning 80 to 9091 , 443 to 9444. This seemed correct, but if I removed these and manually set the port range (using the same numbers) then the NAS box was visible from I needed to disable UPnP on my router, which was not an issue for me.

Don’t know why UPnP assigned mappings were causing an issue, but avoiding UPnP has worked for me.

Hi ther, I also have the same problem. I can log in using the app but not using a browser on the ios moble or a windows 10 laptop.

see solution from Mongbei - thx