My Cloud OS 3 App

Will I still be able to use the My Cloud OS 3 app to sync photos to My Cloud Mirror (1st gen, OS3) on my local network after support is ended?

Hi @Scandioo,

Please contact the WD Technical Support team for best assistance and troubleshooting:

No, you won’t. You’ll need to use file explorer or network explorer to access your NAS locally and 3rd party sync software.

i tried accessing MyCloudMirror OS3 but failed. I tried to connect with USB3.0 cable directly to PC but win10 do not recon the USB device. Any suggestions on how I can get access again?

This isn’t a USB storage device, it needs to be connected to a network router. What is your setup?

How do you uninstall the WD Sync service??

Dear all,
can you please make available a App solution for local acess to WDMycloud mirror?
Support is ended but the customer, that buyed expensive HD from WD needs to keep going using it as local acess.
Thanks and let me know what are the alternatives available.

Did you try this:

I use file explorer regularly to access files.

When I was doing this away from home; I logged into my network via VPN and was able to access files using file explorer.

What about the Photos/backup´s sycronization with NAS? According the informations I got, only the remote acess has been changed. Is that correct?

The OS3 apps no longer work. You’ll need a 3rd part application for syncing.

Can you inform about wich 3rd part App we can use?

Unfortunately, I don’t use any.

I’ve started using SMBSync2 on Android. It works for me. Make sure you use a static IP for you My Cloud Mirror on your local network.