My Cloud not connecting, not reseting


The LED on the front is steady red and I can’t connect to it from my PC. I tried soft reset (pressing 4 secs on reset button with power on) but the red light didn’t change. Tried hard reset (power on with reset button pressed for 40 secs), again nothing happened, the red light still on and no connection. Any more things I can try?


Is this a new device, or an old one that has stopped working? If new, what router is it?

What are the ethernet port LEDs showing?

Have you tried a different ethernet cable, or router port, or resetting the router?

There have been previous discussions about the file system becoming corrupt, which have been resolved by running multiple passes of a disk check; search the forums.

If it comes to the worst, and it’s the hardware rather than the HDD, the latter can be removed and data recovered using a linux machine or Linux boot disk, or an ext4 driver on a PC.


This is an old device, it worked flawlessly for years until now.

One net LED is steady orange, the other if off.

I tried a different net cable, didn’t work either.

Have you looked at the User Manual Ch. 2, LEDs, ?

How long have you left it off before doing a reboot?

That suggests a 100Mbps connection, but no activity.

Did you try a different router port, and router reboot?

Here are some threads that might help:

Thank you for your answers. I tried:

  • Restarting the router
  • Connecting the network cable to a different socket in the router
  • Using a new network cable
  • Connecting the network cable to a switch connected to the router
  • Short and long reset. The reset process doesn’t event start (front panel light stays red)
  • Disconnecting the power from the device for a couple of days

Nothing worked. Assuming the internal HDD is OK and the files are intact, this is my plan:

  • Buy a new 2TB My Cloud (they are the cheapest)
  • Remove the internal HDD (can I put it inside my PC?)
  • Take out the 3TB HDD from the dead device and put it in the new one.

Your comments and advice will be appreciated.


It depends on what version of My Cloud you currently have and what version you buy. If they are both the same version then it should work.

One can remove the hard drive from the My Cloud enclosure and attach (using a USB to SATA adapter or an internal SATA port on the PC) it to a PC running Linux, or a Linux Live/Boot CD, and view the contents of the hard drive to check if the drive is good or bad.

If the hard drive isn’t bad one could see if they can find the exact same P/N number of a used My Cloud enclosure on eBay or the like and insert the hard drive into the new enclosure. The new My Cloud enclosure MUST be the exact same version as the old otherwise the unit won’t boot up. If one buy’s a new My Cloud complete with hard drive it might be worth attaching the existing My Cloud hard drive to a USB to SATA adapter to see if you can access the drive and copy the contents to the new My Cloud device.

If the existing My Cloud hard drive is bad there isn’t much you can do other than attempt to backup the data from the drive using a Linux PC or using Linux recovery programs to possibly recover the data from the drive.

Thanks a lot.