My Cloud Home Set Up Nightmare

Bought a My Cloud Home to replace my My Book Live last week. 7 Days later I have failed to get it to work. Either it appears in Microsoft Explorer as a drive but is not accessible on the My Cloud app or vice versa. Tried re-setting, deleting and re installing the app. Still not managed to access the dash board. To add insult to injury I get an email offering a 40% discount to swop. The My Book Live worked perfectly, and still does. Am at the end of my tether, please any advice?

Cannot Access My Cloud Home Dashboard (

User Manual: My Cloud Home and My Cloud Home Duo (

After a week or so I think I have got it to work. Sonos plays stored music and a back up is working (or so my computer says). The problem I had centred on “mapping a network Public drive” and the request by both Sonos and Win 7 backup and restore to provide an admin log in and password. As My Cloud Home does not offer a dashboard that was a challenge. Not something mentioned on your website. So I rang the WD helpline. The 1st agent assured me that MyCloud Home would not back up Win10 And told me to download Acronis for WD. Contrary to what your blurb says. That proved impossible to get working as Acronis could not “find” my device, even though it appeared in Explorer and as a network device. So I rang again. That agent told me that Acronis was not compatible with My Cloud Home and recommended I tried Win 7 Back up. So 7 days running in computer circles. This time, however, I managed to get the network mapping right. When Win 7 asked me for a user name and password I put in “admin” and a couple of taps on the space bar for a password. To my surprise Mr Gates was happy and my first back up is done.

Please please WD, can you get your agents to speak from the same crib sheet and your help site to give answers that work. The device was nearly on its way back to you. May still be if the next back up does not work.

These folks are from some agency WD outsourced to.
And frankly they don’t know anything.
I have faced many problems with this product and I will recommend that we should buy a different NAS altogether, see my post for the things that will not work with MCH: